One-to-Many Data Relationship Issue

Can’t link the data after having set-up a one-to-many relationship. If doesn’t show in the list.
Goes in a recursive loop instead

It was my mistake. One can actually select the presented options. The data types were wrong

1 Like

Hey man, i’m having the same issue but it seems you have the solution. Care to share?

Thanks a lot!

1- I saw on Slack that this recurring loop is actually a bug. One workaround that worked for my data is to set the relationship as a many-to-many.
2- Then you can select it, but it is not apparent, as the default name of the action i.e. “select from…” shows as a title and blends with the hierarchy formatting, but is actually what you should select. Changing the name of the action helps distinguish what to select.

1 Like

I’ve come across this too - can you eleaborate further on how you figured out which option to select?

Has anybody found a solution to this?
No worries I finally understood after reading it for the 11th time.

I am still not able to do a simple relation like mapping a Customer table to a User table. I need a one-one relation as users can have multiple types.

Can you provide some more context please.