Plugin for LATEX

Hello guys,

I’m trying to build a plugin that renders math functions as svgs however have some problems :frowning:
I’ve created component and run the dev environment according to tutorial Introduction | Adalo

Than I try to install existing library for react-native. I’ve tried those:

However when I try do add the component to index.js and compile → nothing happens. I check the app in dev mod in browser and all content just wanish (even if I had some text added like here:


Than when I refresh app and try to add component once more it shows

All of this happens when I’m testing in the web.

I tried to check few things that might cause the bug:
First I checked the react-native-svg → but it worked well.
Then I tired to change the content in to some html and it worked well as well.

I’m pretty noob in coding so you help will be highly appreciated :slight_smile:

Hi Glib,

Could you open the dev console in chrome? CTRL + Shift + I? Lmk what the errors are to debug the problem.

Here are some bugs for GitHub - webyonet/react-native-mathjax-html-to-svg


This is what I see:

This is code:

After trying to add component once more in Adalo editor I see:

Here is bug report

Could you send me the link for the minified react error?

Here it is:

Ohhh now I now the issue.

Where it says

const { color, text } = this.props;

Remove the “text” from it and it should work, because your not using that.

So it should be this after the change:

const { color } = this.props;

Thanks. Tried to implement but still not working :frowning: Still the same bug report :frowning:
It seems like there is problem when adding Latex equations. Because without it it just showing html fine.

Here is bug report

For sure it is a problem with generating those equations.

I’ve made little modification for the app so I can add those equations directly in adalo:

Then I added custom html (just a paragraph). Works fine:

Than I add equation in adalo. Not working

Add have the same bug:

Bug report:[]=undefined&args[]=

Did you try adding quotation marks around the equation instead of curly brackets?

You mean the particular equation? If so then it shows error during the compiling. Maybe I haven’t understood you well :frowning:

I tried to change import MaxJaxSvg to quotation marks instead of curly but it is still not working ;(

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.