Randomizer Component Not working in one app

Hi community

I am trying to use Randomizer component in one of my apps. It is not working.
I get this message at the bottom of the screen “(i) Action Cannot be Completed”. I’m sure many would’ve seen this type of message in their Native / Web apps.

My use case is very simple. I have a table of users and a table of teams. Teams have many users, users belong to one team. On sign up, I am forcing users to either create a unique team or join an existing one.

When a team is created, I want to create a unique ID using randomizer component output. But its not working in this app. The only table where I can store the output of randomizer using ‘update’ action is the users table.

I created a whole separate mini app in adalo with only two tables to implement this use case. Randomizer works perfectly in that app and I am able to update any table.

I went back and tried generating uiud using two website (UUID Generator API | UUIDTools.com and https://www.randomnumberapi.com/). Custom actions are also having same behavior - working perfectly in mini app, not working in the required app - with the same error message.

I can’t simply delete an existing app and create a new one simply because one type of action isn’t working. While its also strange why its not working.

Any idea what is the issue?

Hi @newbie_maker,

Could you add some screenshots or a video of your setup and preview?

If you like you can give access for your app and I’ll check the issue! ( Open the app in the editor > gear icon on left > app access section > add this email : pereradilon24@gmail.com )

Thank you

Hi Dilon


Here are two separate screens where I tried to generate UIUD from randomizer, but couldn’t.

Error is shown.

Do note the strange part is the only table I can store Randomizer output is in user table.

Can you help?

Thanks

Teddy, could you show some screenshots of the actions?

Hello, can you please provide more information about the configuration of the randomizer?

Thank you!

Thanks Dilon and Ali-Bazzi.

Sharing action on one screen - I am using it the same way everywhere, and on the mini standalone app.

Don’t get confused by the presence of a ‘Generate’ button on the first image, or buttons in my earlier post images. I am using a custom action on the buttons to test via uiudtools.com to generate UIUD via external custom action, as a test. It is a second test on whether the component works, or whether an external service would work.

Here is my understanding of the component -

It is not a triggered component - meaning it does not need to be ‘called or activated’ with a button action. The moment a user visits the screen it is automatically triggered. What we need to do is to utilize the 4/5 different output it produces.

So I am simply importing the UIUD and I want to place it in the User’s Team Profile created immediately before this screen.

Like I said, I have implemented this exact usage in the mini app, and it works on both User Table and Team Table. Here are the screenshots and the action / editor shots of the mini app.

So its not something to do with my Adalo account that some components are failing, or even how the DB relationships are structured, because I have implemented it the same way in the mini app.

Really strange, never happened before. Sometimes all components fail when Adalo fails, but one component in one app is only working in one table.

Please let me know how to solve.

Teddy, can you share a screenshot of the available data in the Create Team Profile 2 screen? And you are updating current profile > team relationship right? If it is does that relationship property is empty or not?

And is it possible share a video showing the full set-up and the preview? ( This may easy instead of sending screenshots :raised_hands: )

Hi Dilon

  1. Create Profile 2 Screen has this available data → “Current Profile - Team”

  2. I am updating the current profile by adding the logged in user on create team profile screen, after the team profile is created. Action on submit button is create new profile - team, action two is update logged in user by linking his property field.

However, regardless of whether the relationship is established or not (it is established, I have checked the data tables), the component should work in any table right?

Apologies for not sharing screenshot, I have replied to you in private.