Scroll position not preserved?

However, it would be super helpful if anything could be done with that. I find it very annoying and time-wasting because sometimes the positions hold, sometimes not and it consumes a lot of time trying to figure this out. When it seems like it’s working, it suddenly goes wrong again.

Hi guys, I am experiencing the same issue and it is very annoying. It makes the app look kind of “cheap”.

1 Like

Hey, @jeremy, experiencing the same issue.

1 Like

I’m experiencing the same issue. For single back action, in previewer and PWA. My users are scrolling through a long list of profiles, clicking a profile to see details, then being taken back to the top of the list when returning (making the profile a Modal screen doesnt help). Is there a fix for this yet?

I was experiencing the same problem. Suddenly it improved slightly. from a scrolling list link to first detail page and back it works. it comes back exactly on the same file on the sroll. but from when i navigate to next page and come back to previous but from there it goes back to the top of the scroll list. to explain better i join the screen shot.
from home to full brief and back is fine but when going back from original article 1 to full brief its fine from ther to scroll page i find myself on the top of the list;

Please help

Hi all, I have answered this many times now :smiley:

On previewer and PWA it will NOT preserve the position when there’s link back action BUT when native apps (Android & iOS) are live it will preserve its position.

On Native apps - to do the trick you will need to set the transition to either Float Up or Modal.

@Niam @Yos @mephix I have several apps that are live and has feed design, tapping it launches the content viewer. It won’t work if you use Push Transition.

Proof this is a live native app > https://drive.google.com/file/d/1HVX3s91UokXUK6suw1wmEZPXc2lYRblO/view?usp=sharing
Like I said just on LIVE native apps …

hi @TORCH, thanks for taking the time to provide this demo for native apps.

I do understand that list-return works in native apps. My point is that it does not work in PWA. I can’t speak for @Niam and @Yos but I would like this to be considered a bug that needs fixing. Because it breaks the experience of scrolling through a list then clicking on one list item for details in a fundamental way. Is there something basic about web that prohibits this from being fixed?

@jeremy It is still happening for a single back action.

We will try and get this working on PWA, since it seems to still be an issue. I thought it had been fixed on both.

5 Likes

@mephix I notice it is working on PWA.
On this example I am working on UI Kits for Adalo Platform where it has a list and the list has link to Edit country Screen, transition is set to modal.

https://drive.google.com/file/d/11e3g4kxdgqs5gblEv6j-dfAEHQwOPxb2/view?usp=sharing

It is now working for me on webapp and in the previewer. (I didn’t change anything, just checked back this morning, so I’m assuming there was a fix).

Thanks @jeremy for fixing it and @TORCH for the help and demos.

2 Likes

Sorry to report this, but it is still not working sometimes. Below is a screen video I took this morning (with no code changed since it was working last).


You can see the jump back to the top of the list. I’ve tried to figure out under what circumstances it happens, but so far it is beyond me. It happens some of the time. @jeremy, I am happy to do more tests and/or provide more information if you need it.
2 Likes

I also tested it out, it’s still jumping back up in my web app when I’m exiting from a modal screen (detail of item) back to a list screen (list of items)

Hello @Colin, wanted to bring this issue to your attention as it’s been bugging some of us for quite some time. Would be great if you could let us know of any updates :slight_smile:

1 Like

This is still currently in our backlog of bug fixes and will be worked on when possible.

4 Likes

I think, this issue not yet fixed for PWA, I’m experiencing the same issue

One of our clients mentioned this. It was tough to explain to him that we couldn’t ‘fix’ this issue (since we’d have to tell him that we’re using a 3rd party and can’t fix it, and that’ll look even more unprofessional on our end), so we had to use a different solution for our workflow, for which we originally bought Adalo for :frowning:

Did anyone find the solution to preserve position in list? it’s really annoying and clients are complaining. please help.

It is still not working for me too

It is still not working for me too !

still not working :slightly_frowning_face:
waiting for solution @Colin