TEXT INPUT FIELD: Why when set to Type "Normal", when entering “0123” is received as “123” in a Webhook (i.e. first zero is ignored)

Hi,

  • Picture below shows a “Text Input” field that I added to a screen in order to capture a four-digit code. This code once entered, and via Custom Action, is sent to Integromat/Make.

In Make, the code is received by a Webhook module which is working well, except when the code starts with zero, the zero gets ignored. That’s my main question in this post: why that zero is being ignored (when I’m supposedly doing the right thing, entering it as a “text” and not a “number”)?

  • Picture below shows in Make how the first zero got ignored (i.e., entered “0970” but got “970”)

QUESTIONS:

1) Using type “Normal” for the ‘text input’ field, correct? As shown in picture above, I’m using type Normal (ie, this is meant to be a text or string, not a “number”), as I was told in a previous forum post here. Is that not the case? Note: in the Custom Action setup, for the text field property I’m selecting “Text” (and not “Number”) but that didn’t fix the issue either.

2) The problem seems to be in Adalo, but would it be in Integromat/Make?
In a recent Adalo forum post,Adalo Community Leader @Victor, stated “It seems to be a weird issue somewhere in between Adalo and Integromat.”, and “I’ve [Victor] submitted a bug to Integromat”. That post is here, Note: In Make, this issue is happening a Webhook module, which is the first one I have for the Make ‘scenario’, so I don’t think removing a zero is something the webhook would do. Anyway, would be issue, could be caused by Make?

3) Would the issue be my Adalo ‘account’? Recently on something else where I was also using Adalo and Make my account apparently was not behaving properly, I was even told by @Victor that I should create a ticket with Adalo (i.e., from Make, he/Victor was able to “add” records to the ‘Users’ collection in Adalo, but I confirmed that is the only function I could not do using the Adalo modules in Make. My description of all that is in this same post I just mentioned, here. So, could it something happending my Adalo “account” level?

Thanks in advance for any help.

Hi @sweetapp21,

As you’ve mentioned me several times, I’ve decided to drop in :wink:

In regards to your question: most probably you’ve set up something incorrectly. I have recreated the environment (not in Make but in Integromat - but I guess their logic is the same) and can successfully get all the zeroes from the input.

This is an app example:

Here is the webhook:

And here is the custom action (input Code is text and is transferred to :

What you can do:

  • check your set up and see if it corresponds to what you see on the screenshot. Also it could be a good idea to see what data is received by a webhook (you can see it here):


    If raw data shows that there are no zeroes in the json - this means that data transformation is done by Adalo.

  • re-create the custom action from scratch, paying attention that you’re operating only with text fields. Maybe you can even recreate the input. Sometimes (this is a very rare case but I’ve seen it) components may “inherit” previous settings, which may cause weird behaviour. I wonder if this could happen with custom actions too.

Hope this helps.

Just in case: this issue isn’t connected to Users creation via API.

Best,
Victor.

2 Likes

Thanks @Victor !

I followed this suggestion and it fixed the issue!

Literally what you mentioned that it “inherited” previous setting. At first I changed the input but didn’t work, so had to recreate the custom action.

P.S. sorry I didn’t mean to mention you that much (hope it didn’t bother)… but you see? it worked! :wink:

Hi @sweetapp21,

Glad you solved it!
Just in case: I experimented with Input format (Normal, Number, …) - it didn’t affect the variable type passed to the custom action. In my opinion Input formatting works just for frontend (data entry).
Anyway, good luck with further app development!

Best,
Victor.

1 Like

Thanks for input again @Victor .

P.S.: I’m still not sure what was the root of the issue, however (after your first message above), when checking the Custom Action setting, I found the “Input value” not only as “Number” but the ‘Sample value’ as “0123” (so included a zero; a bad idea). My guess is somehow part of that cause the issue and got ‘inherited.’

1 Like