Twilio & adalo Authentication error Still not fixed

Hi, i spent the last 5 hours trying to fix the authentication problem, whatever i do it keeps saying that my API AuthSID is not correct, any solution please? i am running out of time.

Although I simply cannot provide support for all API’s out there, I may be able to guide you towards where it may be going wrong. Can you post a screenshot of the setup (obscuring all sensitive data).

1 Like

Ok, Idid a little digging and I can see that Twilio uses Basic Auth. We don’t fully support basic auth yet in Adalo. (Using username and password)

However, you could try encoding your SID:TOKEN as Base64 and trying this as your header.


Basic {base64 output}

If that does not work. My next best suggestion is to use an external API integrator tool such as zapier or integromat, where you will be able to send the info you need to integromat via a webhook and then setup the scenario inside integromat to proceed with the twilio part.


Thanks alot Colin.
i will try it .

Interesting, I was able to get past the Authorization step with no problem with your recommendation but I run into issues with the json body. I get an error with the “to” field. Any ideas on a workaround?


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.