What’s going on with Adalo?

My app seems to be losing the data on the screens / current data missing…

Open the app and it stays stuck on the count down…

And I Launched the app yesterday… to the public… this was definitely not happening before… one other issue I was having with load as user scrolls (it was not loading only 20items was displayed) - this was fixed this morning apparently… but now i can’t even access the app.

Is anyone else having this issue plus other similar issues?

Hey JMB,

This is an issue with how you’re linking data between your screens.

Check out the video here on ‘data not being available between screens’

1 Like

I’m also having some issues on the native app. My app seemed to be working fine 3 days ago but now the “link to next page” does not seem to be working. The previewer seems to be okay, but the native app on my mobile is failing some functions.

If I login to the app, it stays on the login page and does not go to my home page and when I close the entire app and reopen it, it’ll go to my home page. My external API calls are also not working on the native app.

Anyone else experiencing issues?

3 Likes

Yeah thats exactly what happened also, people were stuck on the first screen and had to remove the API call made on it.

:scream:

From my own experience, it’s really easy to make a mistake passing data around.

For example, you might have a setting page that can be accessed on multiple pages. But because this settings page doesn’t have ‘current task’ every page it touches kills that current task.

There’s a few ways around this:

  1. Be super careful about how you link pages. Look at the data that is being passed. It can be so easy to make a new page but each page can make a gordion knot of data passing

  2. If you need to pass data from a page that isn’t carrying that data, turn the button into a list and have it now carry that data

  3. Have fake links that don’t get activated at a page level so that the data is getting to all needed pages

But really, option 1 is the correct action. Be mindful of passing data around, it comes to bite you later. Sure you can kind of hack around it, but then it just makes a bigger headache down the line.

Hi Barrett, thanks for the helpful suggestions but I think something is going on with Adalo, my released app was working fine a couple days back and now its not.

I noticed the problem of linking to the next page (or any other action actually) persists only when there’s a custom action involved on that button. Calls to external collections / API calls seem to be problematic too. There are other posts in the forum with people also raising the same/similar issues.

Please help us!

2 Likes

Adalo Data passing is rough… Really basic stuff like working with “tab” navigation completely breaks unless you do it in a really dumb, hacky or heavily worked-around way. Seems like a lot of the more seasoned folks on here heavily use the “list button” concept to get stuff to work. You have to be careful how complex you make stuff too, as data will also sometimes seem to “fizzle out” after 2 or 3 passes-through, so it’s tough to make serious work flows. You end up having to duplicate a lot of functional screens in your apps so each potential way of doing something has it’s own isolated screen workflow. You’re going to probably have to do the standard troubleshooting step of deleting the screens in question and rebuilding them, hoping it works this time.

1 Like

Joey if you haven’t Submitted a support ticket yet I suggest to Submit a Support Ticket!

1 Like

Just saying if you haven’t done yet!

@Joey this is happening in Native right? Can you try submitting a new build? I saw some posts after submitting a new build it’s solved! ( I believe It’s because after Adalo update something it’s updated on PWA but to get that update on a published app you need to submit a new build! )

1 Like

Yeah I tried that but I can’t get past the login page so Android and Apple has rejected my build.

I’m in a bit of a tricky situation because I’m using Xano as my backend so the login button uses a custom action. So this is where the screw up happens.

I could take away the custom action temporarily to try do what you suggested and bypass the problem but I am wondering if Adalo is on this issue. Thanks for the suggestion though @dilon_perera . Will give it a go if nothing has been fixed by tomorrow.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.