422 Error when trying to update my Airtable base

I have run through the tutorials and read a bunch of forum posts. But whatever I do, I cannot create new records in my Airtable Base. **Any help is hugely appreciated! ** Here is what I have done:

  1. Set up a very simple test base with two text fields: Airtable - test_base (I am on an enterprise account)
  2. Set up a 14 day Adalo trial
  3. Followed this tutorial to the T: Connecting to Airtable - Adalo Resources including adding the Header and Bearer Key, changing Create endpoint to Patch, tested successfully
  4. I am able to retrieve records into a List
  5. set up a very simple form to just update the two text fields.

No matter what I do, I get a 422 Unprocessable Entity error when I try to submit.

The error should describe a little more about what the issue is.

Are you using a custom action?

Previous posts mention that this is due to a type mismatch. However, both the form field and the Airtable fields are Text.

I get two errors. first one (dddd and tttt have actual ids of the Adalo database and table)

POST https://database-red.adalo.com/databases/dddd/tables/ttttt?imageMeta=true&include= 422 (Unprocessable Entity)

Then I get

ERROR Error: Request failed with status code 422
    at e.exports (createError.js:16)
    at e.exports (settle.js:18)
    at XMLHttpRequest.p.<computed> (xhr.js:77)
    at XMLHttpRequest.r (helpers.ts:87) {datasourceId: 'dddd', tableId: 'tttt'}

Hi Tom @Tvollaro,

Just in case - do you try to put a value to “id” field as well in your form? These are generated automatically by Airtable and you can’t put your own value to it.
Just reproduced the same 422 error on my sample Airtable collection, when I tried to include ID.

Best,
Victor.

1 Like

Victor, that is interesting. My form does not have the ID field. However, my database collection does show the ID field listed, but it has a lock on it, and does not let me remove or edit it. (see image below.) I assume that is a safeguard to avoid that problem? Still a mystery…

Have you tried using the Post method for the Create endpoint?

The Update endpoint for Airtable should be Patch but believe it should be Post for creating records.

1 Like

imjohnston, that was it! I could swear I tried that at one point, but apparently not. Thanks so much.

hi @Tvollaro , I am now facing the same issue "422 Unprocessable Entity error " with the Form Component linked to an Airtable collection to create a new record, it was working fine for the past 12 months. If I build my own form, with text inputs and a POST action all works fine. But having the issue with the prebuilt ADALO form component. Anyone facing the same issue?