Admob causing app not to publish

I didn’t realize I already had an admob account with my gmail. I created a new gmail for this app and started using it. Admob then blocked my account saying I had one with my original email. I updated the admob components with the new app id and ad id, but now my app won’t publish (when i go to publish then click start new android build). I haven’t tried ios yet so this is only for android. I removed all the components but one and it still did it. I removed that one component and it downloads fine. So it’s definitely the admob component that is the issue. Does anyone know how to fix this? I submitted a ticket but I know they are busy and can take awhile to respond.

Here is the log of the error:

FAILURE: Build failed with an exception.
stderr |
stderr | * What went wrong:
stderr | Execution failed for task ‘:react-native-google-mobile-ads:compileReleaseKotlin’.
stderr | > A failure occurred while executing org.jetbrains.kotlin.compilerRunner.GradleCompilerRunnerWithWorkers$GradleKotlinCompilerWorkAction
stderr | > Compilation error. See log for more details
stderr |
stderr | * Try:
stderr | > Run with --stacktrace option to get the stack trace.
stderr | > Run with --info or --debug option to get more log output.
stderr | > Run with --scan to get full insights.
stderr | > Get more help at
stderr |
stderr | BUILD FAILED in 1m 29s
stdout |
stdout | Deprecated Gradle features were used in this build, making it incompatible with Gradle 9.0.
stdout |
stdout | You can use ‘–warning-mode all’ to show the individual deprecation warnings and determine if they come from your own scripts or plugins.
stdout |
stdout | For more on this, please refer to Command-Line Interface Reference in the Gradle documentation.
stdout | 292 actionable tasks: 288 executed, 4 up-to-date
stdout |
stdout | info :bulb: Tip: Make sure that you have set up your development environment correctly, by running npx react-native doctor. To read more about doctor command visit: cli/packages/cli-doctor/ at main · react-native-community/cli · GitHub
stdout |
stderr | error Failed to build the app.
stdout | Error: Command failed with exit code 1: ./gradlew app:bundleRelease
stdout | at makeError (/tmp/build-6PgBRD/AdaloApp/node_modules/execa/lib/error.js:60:11)
stdout | at module.exports.sync (/tmp/build-6PgBRD/AdaloApp/node_modules/execa/index.js:194:17)
stdout | at build (/tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli-platform-android/build/commands/buildAndroid/index.js:68:22)
stdout | at Object.buildAndroid [as func] (/tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli-platform-android/build/commands/buildAndroid/index.js:60:10)
stdout | at Command.handleAction (/tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli/build/index.js:118:23)
stdout | at Command.listener [as _actionHandler] (/tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli/node_modules/commander/lib/command.js:482:17)
stdout | at /tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli/node_modules/commander/lib/command.js:1283:65
stdout | at Command._chainOrCall (/tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli/node_modules/commander/lib/command.js:1177:12)
stdout | at Command._parseCommand (/tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli/node_modules/commander/lib/command.js:1283:27)
stdout | at /tmp/build-6PgBRD/AdaloApp/node_modules/@react-native-community/cli/node_modules/commander/lib/command.js:1081:27
stdout | info Run CLI with --verbose flag for more details.
stderr | error Command failed with exit code 1.
stdout | info Visit yarn run | Yarn for documentation about this command.

  • code: 1

exec error: Error: /scripts/ exited with error code 1 (signal: null)
Error in buildAndroid: Error: /scripts/ exited with error code 1 (signal: null)
at exec (/scripts/lib/exec.js:129:13)
at async buildAab (/android/buildAndroid.js:398:3)
at async callback (/android/buildAndroid.js:572:55)
at async run (/scripts/lib/steps.js:25:53)
at async Object.execute (/scripts/lib/steps.js:41:50)
at async buildAndroidUpgraded (/android/buildAndroid.js:577:3)
at async Queue.processAndroidJob (/android/index.js:100:9)

Hi @nsamardzija It seems react-native-google-mobile-ads package issue, they have recently released new version (ref; GitHub - invertase/react-native-google-mobile-ads: React Native Google Mobile Ads enables you to monetize your app with AdMob.

How do i fix it on my end though? Its still not working

can you please share the image of the component which you used?

AdMob Banner


Hello @nsamardzija! Please submit a support ticket through this link: Submit a Support Ticket

Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.