Airtable: linked data between screens not working

URGENT HELP
Screens are not inheriting data after creating a new record from the previous screen.

I submitted a ticket, but the issue is urgent

1 Like

me to

1 Like

I can imagine that the issue is linked from Adalo last patch on Airtable API 🐞Bug Fix: Error When Adding/Updating/Deleting Records In Airtable External Collections | Adalo Changelog
do you have any update @jessehaywood ?
I followed the instructions to reconnect the external collections, but now this issue happens on Desktop Web Apps. Urgent help/support on that matter please. I have no other way no make my apps work.

Also having this problem today, and also a pretty serious issue for me. Records are being created through a button press on one screen but then the update record form on the next screen is not sending any data.

Have resynced the external collections again as suggested in the link above but no changes for me (both native and PWA)

[Edit to add: the screen with the update form is showing all the correct linked data and the form appears to work (no error message on submission), but nothing is updating in Airtable after the initial record creation.]

On another note, if something has changed that impacts the workings of our apps and requires action on our end it would be nice to be emailed or informed about them instead of having to find them hidden on the changelog!

2 Likes

couldn’t agree more :frowning:

I replicated the issue below, with a simple APP, on one side an Airtable collection and on the other side an Adalo collection, after creation of an Adalo record, the data is linked perfectly & shows up to the next screen. Then, with the same configuration with Airtable, no data is shared on the screen after the record creation.

an URGENT patch on that is needed here

1 Like

After re-syncing the collections I’m able to edit existing Airtable records but not update records that have just been created on a previous screen.

So 2 scenarios in my app; both were working fine yesterday but now scenario 2 doesn’t update the record in Airtable:

Scenario 1: Editing existing record (working)
I have a screen with all records. If I click on a record it takes me to a screen with a regular form set to update current record. I can successfully make changes to the record using this form.

Scenario 2: Create then edit record (not working)
I have a button which creates a new Airtable record and then links to a screen with a form to update that newly created record. The record is being created without problems. The update form on the next screen appears to work correctly (form is submitted and app links to the next screen properly) but the newly-created record isn’t being updated in Airtable.

To confirm, both scenarios above were working fine up until today.

1 Like

I’ve received a few DM’s about this as well. I’ve asked the team about it. Hope to get you an answer soon.

One of our CX team members said he had a ticket who created an example app and he followed the instructions on the changelog and it seemed to solve the issue.

1 Like

Hi @jessehaywood , the BUG FIX you are mentioning “seems” to have caused the issue of data inheritance between screens for created records , before that fix it was working perfectly (the bug fix did however fix some previous issue with airtable collection forms, but this is a new issue)

Adalo has fixed the inheritance issue, however a new issue is reported: impossible to modify (PATCH) any existing airtable records : error-422-unprocessable-entity

Also still having problems with this. For me, the built in form is now not working at all to update an Airtable record. When inspecting the request in Chrome I get the same error as @intimur above: Error 422 unprocessable entity

If I set up a custom form and edit the record using a custom action it goes through fine but we need this working in the native app for events happening tonight and over the weekend so that doesn’t really help right now.

I’ve tried deleting and re-adding the built in form and I’ve reconnected the External Collection as suggested above. Very disappointing when this has worked without issue for the last 3 months.

Adalo should figure out a way to integrate all these third party platforms, like airtable, send grid, etc + components so that, everything works, easily. I wish I could just drag, drop, adjust … like the Adalo’s core product.

Not sure of the implications … simple logic says, it would prevent a lot of issues. And would be easier to use for no code monkeys like me.

1 Like

To Add here,

I did refresh the connection between Adalo & Airtable using the “Edit Settings” option 8 hours ago and it was solved which means the update record in Airtable function got working.

Later 4 hours ago, it again showed “Action cannot be completed”.

Now a few minutes ago, I refreshed the connection again, and the update action is working.

This function is affecting one of our major features, I look forward to having a permanent solution as soon as possible as without this function using users will not be able to use the app as it is effected the main feature in the app.

Thank you!

2 Likes

Got a way to resolve the update record issue, when you refresh the connection be sure to have /{{id}} at the end of your table url for the PATCH method (as for get one & delete)
…don’t know how I missed that one

image

@intimur Thanks for the reply!

Your recommendation was the one I tried 8 hours ago, adding /{{id}} at the end of “Patch” url. It got worked then.

Unfortunately what I have put in the end of url /{{id}} got vanished later and the issue continued.
adalo collection settings

thanks for the update, dam…meaning that the settings “auto” refreshed and cleared the /{{id}} on the url?

@intimur Yes, You are right.

To add to it, right now the update action is working after the latest refresh 1 hour ago.

I would like to wait for some more time to confirm whether this gives a temporary fix or not.