Creating New AirTable Records

I suspect this is a bug. This just started this week. When a new record is created in AirTable, the app will not link to the next screen. As expected, the record creates in AirTable, but the Adalo app will not proceed. The error in the console is:

instrument.ts:129 TypeError: Cannot create property ‘id’ on string ‘’
at f (metadata.js:44:3)
at t.indexObject (metadata.js:102:12)
at t.default (data.js:233:15)
at combineReducers.js:120:29
at persistReducer.js:147:20
at f (createStore.js:165:22)
at index.js:88:26
at index.js:11:16
at dispatch (applyMiddleware.js:35:18)
at index.js:177:11

All experienced AirTable users know that you do not specify the ‘id’ when creating a new record. I came across this bug when updating the app for an unrelated reason and noticed that The app did not display my confirmation screen.

How to reproduce the bug:

  1. Create a simple AirTable table with just a name and age
  2. Connect the AirTable to the Adalo app as an external collection
  3. Populate ‘John Doe’ as the name and 20 as the age
  4. Attach the Create action to a button or a text link, then add a second action to link to another screen (Home, anywhere, does not matter)
  5. Run the app in preview. The record will create in AirTable, but the app will not progress to the linked screen. (It just sits there) If you press the button/text attached to the create action again, it will create an AirTable record each time you press it. i.e., Press it six times, and you will get six records.
  6. The Adalo app will sit there and let you press the button thousands of times without progressing to the following action to link to the screen your specified.

This obviously causes an issue with the end-user because from their point of view, it’s not working; even though records are created in AirTable, to the user the button/link is doing nothing.

1 Like

Any word on this post? Does Adalo look at these?

Hi @Warith,

I’m sorry that you are facing this issue!

I think this is a bug. Faced the same issue and submitted a ticket. For now the way that worked for me is to use a Custom Form.

The best would be Submitting a support ticket.

Hope it will be fix soon!

Thank you

Hi @dilon_perera - We are using a custom form already, and we have the same behavior. We opened a ticket, and the support rep indicated they would escalate it as a bug. Our issue now is the amount of time that has elapsed.

1 Like

Hi @Warith
I had the same issue then I deleted the value of “Results Key” in the collection config and it’s working now.

1 Like

Hi @Warith,

I got a message from Jessi that she said this should be solved!

Hi Dilon,

I have received communication from our team that a release was made to the platform that should address this issue and resolve it for you.

If you still experience the same issue again, please let me know asap so that I may escalate that to the team immediately.


I just checked and it’s working for me again! Can you confirm too?

Thank you