Any GoDaddy domain owners? Adding DNS CNAME doesn't work

Hi there,

Read a lot of topics here about custom domains, but none of them helped me.

So I have test setup for custom domain loading without success.
I use GoDaddy as domain provider. My domain name is “

Can anyone who use GoDaddy domains help me how to add Host Name to CNAME. It doesn’t want to be added with “.” after (like it’s explained on my screenshot)

I’ve also tried to use “www” as a Name with no result.

Thank you in advance!

I’m attaching screens of my DNS settings here


Hey! Is there a reason you’re not using Cloudflare to manage your DNS?

I’m use GoDaddy to manage my domains but the DNS management there is awful.

If you set up a free Cloudflare account (easy to configure with GoDaddy) then you’ll not only get access to all their CDN features but their dynamic DNS features will also make it MUCH easier and faster to manage your CNAME, TXT, MX records (took seconds to configure Adalo).

It’s more than a quick fix (should take 30 mins or so) but it’ll solve this issue (and unlock a load of other benefits) if you can find the time to make the transition.

Best, A

1 Like

Change this to @ not your website name on go daddy

Hi @arthurrjw,
I’ve heard about CloudFlare, but never used it before.

I’ve registered and connected my GoDaddy to it. It was quick, you are right!

But I still can’t add the needed CNAME. It said that the record already exists.

Could you please share how you configured it for your app, please? so I can compare.

Thank you!

I’ve tried and it comes up with unexpected error :frowning:

Hi @bentsajulia @CopyThat @arthurrjw

As far as I know (ok, seen that yesterday in person), GoDaddy does not allow to create a CNAME for a domain itself ("@").
When you try to create a record, Type = CNAME, Name = @ and Value =, the interface refuses to add such record.

It seems that standards somehow forbid to have CNAME for root domain. There is a good overview article here:

and a discussion here:

I didn’t find any workaround for that, except that using a different name (i.e. or smth similar). According to the article, Cloudflare somehow overrides this, but I didn’t try it myself so don’t know how it works.

Hope this helps.


1 Like

Hey @bentsajulia

If you’re planning to host this at the root domain, not as a sub-domain then you should…

FIRST: Delete the “A” record (the first one on your screenshot) since this is why you’re seeing the “already has a record” error.

THEN: Create the CNAME as follows:


(Looks like there’s an extra dot after the .com in your screenshot, you don’t need that!)

1 Like

@arthurrjw Hi again. Thank you so much for your input here!

It works now!
So appreciated!


Hi @Victor,
Yep, it seems that with GoDaddy it’s impossible.

I’ve fixed it by applying what @arthurrjw said via CloudFlare.

Thank you for your efforts to find all this info!

Adalo community is the best!


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.