CloudFlare, GoDaddy, register.com WHY NOTHING WORKS? Dns problem (I think?)

Please guys I have been talking with godaddy.com and register.com customer servicefor days now, I have now bought domains even on clodflare but it is just impossible to publish a webapp on a custom domain. What do I have to do? Screenshots attached @Victor You seem to be the most brilliant on this topic, would you kindly help me? Many thanks



Hey there @matterbm

When you’re adding your domain to Adalo, you need to add the subdomain and the domain.

Hello, I fixed it using a simple dns checker, I was able to understand what the mistake was. Isn’t true tho, if I write www in the adalo custom domain it won’t report the rest of the domain. My domain provider was adding to the cname name the domain right after the cname name. I had to register adalo under a subdomain that points to the root domain

i tried it will google and that did not work ether

Just in case: by DNS standards it is not allowed to have CNAME records for root domain. See here for example CNAME Record - How it Works, Alternatives & Advanced Use Cases, look for Restrictions section.

E.g. you can have a record
www.somedomain.com CNAME hosting.adalo.com,
but you can’t have a record
somedomain.com CNAME hosting.adalo.com.

Some companies like Cloudflare allow creating CNAME for root domains though, using some custom workarounds.

Best,
Victor.

1 Like