Custom domain could not be verified. DNS settings using Godaddy domain through Cloudflare

Hi, I have seen a couple of these posts about the same DNS issue, but the answers given have not worked for me yet, therefore I am making a new post here hoping that someone could give me their opinion. I am quite inexperienced in DNS records, so bear with me :blush:

I am building a progressive web app, and want to add my own domain I purchased on GoDaddy.
Basically, I am not able to add a custom domain in Adalo, it gives me this message:

  1. This made me try all the different DNS settings in GoDaddy that people were recommending on this forum, like using"@" instead of “mydomain.com” in the CNAME record. This did not work, and I got the same message as in the above image. I waited two days in total in hopes it might “propagate” (don’t know if I’m using that correctly, but anyhew :sweat_smile:) and tried to connect the domain on the Adalo settings several times, to no success.

  2. I then tried using Cloudflare as was also suggested to work for some users on this forum with the same problem. Still the same message. These are the DNS records I currently have on Cloudflare, and how it looks like for me in Godaddy.

I would really appreciate someone pointing out what I am doing wrong, and how to get my custom domain to work on Adalo.

Extra info:

  • I have a paid membership on Adalo.
  • I bought this website on GoDaddy specifically for this app, and it has not been used before. I think I am wanting to use the “root domain”, but I don’t really mind not using the root domain if that would make this work (if that makes sense).
  • Adalo’s subdomain for my website has never worked either, and I haven’t been able to choose it as a domain either. I seem to remember that is due to me building a PWA, but I thought I would mention it as well just in case.

I would really appreciate any help on this one!
Thank you very much in advance!

try off the cloudflare proxy first.

1 Like

I tried turning it off and it didn’t work, unfortunately.

my exp is turning off, wait for an hour or two, verified again

1 Like

I had no issues verifying with GoDaddy. My domain is there and I verified it in no time.

When you move your DNS records to a different provider, there will always be propagation of those records. So maybe, you tried to verify while the information was not yet fully propagated.

You can check on your own if the information is propagating using this website: https://www.whatsmydns.net/.

If you are testing a CNAME like app.yourdomain.com, then you have to enter the full subdomain: app.yourdomain.com.

Same thing if you want to test where www is pointing to, then you are testing for CNAME and you enter www.yourdomain.com.

If most of the servers in that tool are detecting the information, then you are good to go with the verification. If the tool is not showing the values, then it’s an issue with propagation or with the DNS settings.

1 Like

Okay, I found out what the problem was.

Silly reason but worth mentioning here because there will probably be more clueless people like me :joy:

  • I bought a domain specifically for my Adalo app.
  • I did not complete the setup in GoDaddy before trying to connect it, so therefore the domain was not hosted, and you do need to pay extra for that. (In case you are wondering like I was).
  • I made a new website in the GoDaddy website builder with the newly purchased domain, which updated the A record in the DNS settings for the domain, and then the CNAME record I added, with the value “app” pointing to #hosting.adalo.com" worked.

Thank you for the replies!

A few notes on my experience with GoDaddy:

  • I have never needed to pay extra to manage my DNS.
  • Every time I have purchased a domain with them, DNS management is automatically set up
  • Once DNS management is in place (which only takes them a few seconds), I have been able to set it up to my needs. In this case, pointing a subdomain to Adalo with no issues.
  • I have never paid extra to GoDaddy to achieve this. I have only paid for the domain, and that’s it.

Did you talk to GoDaddy support? Did they advise you to do all that and pay extra?

1 Like

Okey, thank you.

No, I decided to try it on my own. It works now, so I’m okay with paying the price, although it probably has had a free solution as you say.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.