Anybody used maps?

I’m unable to configure on our app. I followed each step , I might have missed. Can someone help me?

Probably best if you explain exactly what you mean - how far have you got and what isn’t working?

First step: copied API key
Second steps: enabled geocoding api, JavaScript api and ask for iOS
Third step: chooses single marker
Fourth step: manually updated address
Fifth step: Style selected as roadmap

But in the preview I’m unable to fetch anything. It shows blank.

2 Likes

Can you see the map at all? If there is an API key error, you’ll see a red error bar where the map component should be. If you can see the map but not the marker, check that the address is correct (and that if you type it into Google it shows the marker where you’re expecting). If you can’t see the map at all, try just creating a new screen with only a map on it and recreating the issue to see what’s going on.

I’m unable to see the map itself

Ok, this suggests it might be in a hidden group or behind something. Have you tried the process completely afresh on a new screen with just a map on it? If there is an error in the setup, you will see a red bar where the map should be. This will help you to narrow down where the problem lies…

@dosandco I can see the map but showing the wrong location except my device location and how can I search in the map (marked item)? Need help buddy!!

Ok, this is progress! I don’t quite understand the bit about your device. You need to set the map’s marker address to be a Collection’s text field (which contains that address).

@dosandco It’s working!! Thanks a lot buddy :innocent: :heart_eyes: :heart_eyes:

Did you ever resolve this?? I’m having the exact same issue, map does not load with page preview…

Ensure that you have set up all the correct API endpoints enabled and that you have input your credit card through google developer. If you want to send your login email to me via DM I can try and take a look at it as well.

1 Like

Hey Ashley! I have the same problem, it doesn’t display the map and now I’m stuck I can’t go further. I wanted to ask you what you meant by “correct API endpoints”?
Best.
Ben

There are 3 API’s that you need to ensure are enabled. This help doc tells you which ones, Adalo | Maps. Also check your addresses very carefully. If there is 1 address that doesn’t bring up a single point on maps.google.com then it will not show the map. Also verify that you have your markers set with the correct data.

1 Like

Thank you for your answer.
I enabled those 3 API. It seems that it sends the request on my panel on google as I have my figures which change but nothing else. I allowed my location on my browser too but nothing.
Which kind of data do you use for your markers? I tried with “address”, “postal code” and “city”, got nothing :confused:

I got it working on your app. I added the city and postal code magic text. It worked for me as the logged in user.

Hi Ashley,
I entered the same address as you and it effectively works while it doesn’t when I enter my address in Sweden.
Anyway, thank you so much for your help, I can now continue to work on it!
Best regards
Benoit

I can’t seem to get the map to show its just blank and have followed all steps.

Hi @lystpros welcome to the forum.

Please could you make a new topic and give specific details and screenshots of possible of how you setup your map component. (Be sure to blur out your API key in any screenshots).

Mines is blank too. It doesn’t show up in preview

how to zoom in on the map as default?

how to use emojis instead of the red pins?

@ashley