Apps not working

Hi,
Anyone with same issue? My apps stopped working.

Hi @sebastas,

All working on my side using PWA, are you still getting an error?

same im getting blank screens :frowning:

I’m also getting blank screens when i view certain screens in my previewer, i thought it was something i’d done!

1 Like

I know there’s some planned downtime but i think that is tomorrow am early for the US

All working fine on my side of the world EU, as mentioned above there will be some maintenance so it looks like we have to be a little bit patient. :crossed_fingers:

1 Like

Some screens are blank on my web app too

Apps seem to work for me at the moment (9:40 UTC), tried various ones.
Just for the info

Thanks @Victor I’ve raised a ticket for this to be looked into.

I’d taken a copy of my app a few days back and it happens there now too. Someone else in my team logged in and they can view the app screen which I cant, it’s all very strange… the app started behaving strange yesterday evening

1 Like

Just as a hint - did you try to access the app from “Incognito mode” in the browser, and/or clear the cookies?
Sometimes this may help.

Otherwise hope that the issue will be resolved.

Best,
Victor

1 Like

Ok now I have it as well. The app worked yesterday, but today I get blank screen at some point.

Here are the console messages:

I found the root cause for my case.

It was the Image component on the screen, which had a placeholder image. When I hide this component, everything starts to work.

Definitely this is not the expected behaviour… but if one needs develop the app right now, it is worth trying to hide images with placeholders at for a while.

Best regards, Victor.

3 Likes

Thanks, that seems to have done the trick for me!

Out of interest, how did you spot this… was there something pointing to the image being an issue or was it trial and error?

Thanks!

Hi @MM792,

Well, it was more based on experience & approach.
Screen is blank -> app is crashing -> some component is causing this crash. I didn’t see any pointer in console, except that the connection to backend is n/a. First I thought about bug in a form, turned it off - no luck. Then about some wrong DB response, so turned off all components filled dynamically, no luck. The only component left was static image :rofl: (and you usually think that static components should not cause bugs :)) ). So I turned it off and turned back some of older ones - voila, the problem is identified :slight_smile:

2 Likes

Wow Victor you’re literally amazing! I wish I understood what I was looking at in that screenshot picture, believe it or not tho you gave me so much relief knowing that its not something bigger causing my blank screens! Thanksss

1 Like

The same issue at my end… started happening yesterday and still persists.

Interestingly it’s happening only on one screen; other screens also have placeholder images but a blank page is not happening there.

2 Likes

Yes can confirm i’m getting the same behaviour here… I was about to post a bug, but will hold off until maintenance has been done.

1 Like

For me was more I noticed when running app with URL with “target=478asdkjlmxucmv00q6defqb1l1hktp&params=xxxx” it was not working. when I removed all and just left the domain, it started working. I never had blank screen, was just buttons and drop-downs or submissions were not working at all.

1 Like

removing place holder image is the fix currently

1 Like

My App was not working too.
After I removed placeholder, it has been fixed…

1 Like