Bug in the conditional actions?

Hi I’ve made a button with a “create” action. I want the action to be performed only the first time, so I used an advanced action with the condition like:

“current number of rows in the table”
is not equal
“target number of rows”

It seems to me that there is a huge bug here as the condition works at the opposite as it is intended

for example:
create sometimes only if=
“current number of rows in the table” = 0
is not equal to
“target number of rows” = 1

works fine only if I set the condition as “is equal”.

I’m sure of the counts as I put some text boxes in the preview to monitor the input of the conditions

just to let you know…

Hi @Alessandro.ferrarese,

Just tried and for me it worked!

What happens if you delete the Create action and add it again with the condition?

Is there any filters on the conditions hat may be wrong?

And also try with is equal to>0   and   less than>1   to see if it works! For me works!

Thank you

Hi I had already tried with a condition like “first number < second number” (both numbers are dynamic) but it didn’t work
I tried to delete the action and make a new one but with same result
I have no filters

to me, there must be something about how I generate the numbers for the test

my data structure is like:

  • scenario

the button create a new evaluation linking current objects and current attribute
each objects is evaluated for each of the attributes
the condition is like:
current attribute’s evaluations count
is (not) equal to
current object’s scenario’s objects count

The counts are correct, it should be “not equal” but it works with “equal to”.
BTW I’m ok, till it works:) it’s only that the behaviour here is really strange

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.