Anyone found a workaround for clearing a text input?

It seems to be broken when creating an action on button press for it.

Have you tested this method ?


  • My english is broken :frowning:

Same problem here. It had worked but now does not. @devrimdmk that’s how it’s done but it’s broken.

I’m also experiencing problems passing values between screens, and having the inputs not work right if you leave a screen and come back, for instance if a Modal pops up.

This is a real bummer for me because I have a lot of functionalities set up that use input values to control visibilities, states, etc and half of them don’t work correctly now. I’ve re-built some areas of my app to work differently and not use that functionality, but I haven’t found a fix or workaround.

Yet another “confusing” BUG. There’s more every day. The longer my app lives in the editor, the more bugs pop up. It’s really sad to go back to sections of the app that were working perfectly and fully tested weeks ago only to find them completely broken with no way to fix.

Today I’ve spent the ENTIRE work day trying to get a screen with 2 lists working, which was working fine a few days ago, but now is giving me the “White Screen of Death” on PWA and in the previewer. Unbelievably frustrating. No forward progress today and in fact I still haven’t solved it so I’m further back than I was yesterday…

1 Like

I hope this will be resolved very soon !

One thing you can do here is create a text property that remains empty all the time in the User collection called “Reset Text (keep empty)”. Then, whenever you need to clear something, just set the value of the property as the Logged In User’s > Reset Text.

1 Like

Long time, good to see! You da man @pford

1 Like

Yes, I have been using this tip from Michael Ionita’s YT Video @ min 37:55 to be specific (Ultimate guide on how to create a CHAT feature in Adalo (Text, Images, Chatrooms, like WhatsApp) - YouTube)

Works for me like a charm! Hope it works for you too without issues

I’m having a similar issue. I had this function working last week (see photos below) but now I get the error message in the second photo. It’s making moving on kinof difficult because I need to see if it works, part of my app needs faux tip amounts to test it. Can’t really do that if the buttons are set up properly but still don’t work.

I’m actually trying to do it like that but it’s not working, the idea is the user never leaves the screen and I want the text input to reset as soon as they submit the previous text


@Mohammed - Could you link the video again please? You sent a link to his channel, not the specific video

Apologies for that, here is the exact video

It works for me without having to leave the screen, I have this real-time chat built into my app

@Mohammed Ohhhh I see what the trick is now! It works! Very great tip, thanks dude!

For anyone else - Create a second text input on the screen, set the change input new value as the new text input’s value, then delete the new text input and leave [deleted] as the input change.

Glad it worked for you too! Happy to help anytime, good luck with the rest of your app build

Some for me, some of my apps suddenly stop working without any reason… Cannot complete action or input field stopped working

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.