Can't update Airtable Record using a custom action


I am trying to update an Airtable record via a custom action and can’t figure it out. I can’t use the normal Update option in Adalo because the data being edited does not come from AirTable. I am using the standard User database in Adalo but send a copy of the initial record to Airtable via Zapier.

Once the new user is logged in and fill out the additional required profile information I would like to update their record in Airtable. I have the databases connected properly via the API but can’t figure out how to do updates/Patch.

I search all over for examples and was not able to find any. Sorry if they exist.

I have attached a few screen shots. I tried to follow the AirTable API examples but clearly I am doing something wrong. My only guess is I don’t have any ID record I can match to.


I am having a similar issue using PATCH to update records in Airtable.

@markleyave I think it has to do with the inability to match record ID’s between Adalo and an external database. It would be nice if someone from Adalo could address this. There is no regular visibility to a “record id” or unique ID in Adalo from what I can tell l that could be used.

While I have solved some things in my application using Zapier, Zaps do not work with updating records.

I have also tested some things with Postman that appear to work but cannot carry that over to the Adalo API.

Hopefully, we hear something soon. Thanks for your contribution.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.