Custom Patch Action to Airtable - Test Works But Not Updating

Hi - I have a custom action that works during the test but when I preview the application, the Airtable record does not update accordingly. Originally, it was a second action (after an Adalo form update, also update/patch Airtable), but I also tried it as a standalone button after passing along the relevant data to a new screen. In both circumstances, the Airtable record is not updating. Any ideas?

Screenshot of custom action, which is updating an existing record in airtable by record ID. This works when tested and updates the example accordingly, and I believe JSON is formatted correctly.

See test run working:

For how this integrates into my app: I have a form that updates the Adalo database based on inputs, with a pre-existing column in Adalo that equals the Airtable record ID (from creation using Zapier, manually checked as well).

Then, on a new screen I have a button that runs the custom action and should update the Airtable record based on the new Adalo record (from form input/update).

But, at this step the Adalo record is updated but the Airtable record does not update and shows no error signs. Any ideas?

I think I had the same issue with updating records in Knack database too.

When you got test successful, was the record updated in Airtable?

Is it s linked record?

  1. It is not a linked record

  2. Yes - the test successfully updates the related record but it doesn’t happen after the testing

Thanks for the information. i guess this is happening because of the dates in your action. When you test you might be using a standard format, but when you send for previewer it’ll send the UTC format which could potentially be causing the issue.

As a test, remove the date field and try updating a text field and check if that’s the issue. If it is, you need to then work with the dates to fix the issue.

Hi - I tried removing the dates from the action completely but I am still facing the same issue.

Have you tried replicating another Action with different Airtable base or same base just to double check?

I’ve noticed that as well as the dates issue, any field that does not align with the format of the data being sent (for instance a text field that is receiving integer data) will cause the call to fail. It also doesn’t seem to like sending empty (i.e. null) parameters to Airtable. My personal experience has been to only send numbers and text to corresponding number and text fields in Airtable as well as make sure not to send empty fields.

Interesting - thanks @pfordmedia and @JL_LJ, I will try both of these things later this week and get back to this thread. (I do think one of my fields may have been null/empty.) I also tried shifting to a PUT request instead but still no luck there.

1 Like

Hi all - it was the date formatting that was not letting the patch request work. It works now with only text fields, perhaps I had done something wrong previously (apologies!)!

That said, are there any workarounds for still patching date fields? I did some digging and see that JSON needs to formatted as follows “YYYY-MM-DD HH24:MI:00:000z” but I am not sure I can change the formatting of inputs / records from Adalo to match