CSV File Upload Errors - Adalo to Adalo data migration

I’m moving data from a live app (built & currently functional in Adalo) to a new app (not yet deployed with Adalo). And the import fails every time. I’ve tried in Chrome & Safari browsers, and get the same result.

The data is migrating because database relationships needed to change to meet user demands.

Any ideas?

I had that problem once and it turned out to be there were some extended characters in the database like ALT + 4 [:diamonds:] or ALT + 3 [:heart:]. As soon as I took the characters out it worked.

1 Like

How did you identify those characters? I’m not sure what to look for.

That’s a good question. In my case I specifically added the characters so I checked on a hunch and was right.

Sometimes, when copying and pasting, strings with apostrophes get messed up and you find weird looking characters in their place. These should stand out when looking through the database. MS Word and Excel can be a source as can copying and pasting from editors which support double bit fonts like Japanese and Chinese.

Where did the database content come from? Did you copy from a web page? Did you pass it through a word processor? Sometimes you can strip these Unicode characters out by pasting into a text editor first.

These are some of the characters to look for: https://www.alt-codes.net/

It’s an Adalo database to Adalo database migration. In the video you’ll see that I download the Users CSV from a live Adalo app. But get an upload error when trying to upload it.

I have a hunch this comes from the Apple “Hide my Email” & password fields. I can leave out the Password field in the migration, but not the email field. /:

And have no idea how to diagnose or fix it otherwise…

I mean about the original data. Where did it come from? Is it just users? It’s unlikely that the e-mail field has extended characters, unless Hide My EMail inserts the confounding data. Search around for that.

All of the data was user generated (Name, Email, Password, Profile pic, etc).

It seems like the issue is the hide my email & password fields. In the most recent attempt, I did not sync / carry over the passwords. Data for 193 Users successfully migrated over. And lost 7 Users. All of those Users whose data did not transfer had created accounts with Apple login, using the “Hide My Email” option.

Thank you for your help & leading me towards a solution!

1 Like

Glad to hear it worked out. Others will definitely run into this problem.

1 Like