Getting error when uploading a CSV - should this work?

*** Warning: Adalo newbie alert ! ***

Note: I’ve sent this as a support ticket but didn’t hear back so trying here instead.

I’ve just started exploring the Adalo platform… when I was testing the uploading of a CSV as a dataset (i.e., the upload process just hangs indefinitely… when I open the browser console in Developer Tools, I can see the following error reported…

**Uncaught TypeError: Failed to execute 'readAsText' on 'FileReader': parameter 1 is not of type 'Blob'. at index.js:92 at r (2.cfd312a6.chunk.js:1)**

I also tried uploading a much smaller CSV but get the same error each time and the upload never works… is CSV uploading working in Adalo? It’s must-have functionality for me.


Hi @JohnC ,

Just an idea, create 1 record then export it, you can use this as template for importing.

There are a few things that break Adalo’s csv import e.g.: If your data contains single quote marks, non-US date format, and some other stuff- search the forum. The thing is just to try loading parts of your data and by seeing which loads and which doesn’t you’ll find the characters or field that’s causing the error.

Quicky scanning your data file I’d bet it’s either the apostrophes or the “&”. Try loading just those lines and see if they fail with and without the characters.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.