CSV import comma


I want to import a lot of text in Adalo database with CSV import function.
Unfortunately in the text, there are commas…

Is it posible to tell adalo to use another symbol instead of comma ?
Or is it possible to tell adalo the commas are the text and not commas for the CSV. For exemple with “,” or with ,.

Hi @Nirvana,

You mean you want to import the commas too or not?

Thank you

Yes I want to import the commas too.

I found a workaround, I delete the commas before importation. Then I add the commas in Adalo. But it’s a waste of time.

I just tried exporting a collection that has commas in the texts and again when I import that CSV in Adalo I got the commas. If you don’t get them you can use Google sheet and download and then upload! : Ñ Symbol showing "?" - #4 by dilon_perera , Accent marks don't come through when I upload a csv - #2 by dilon_perera

If I have 2 text fields of text.
For example in the cv:
Word 1, word 2, word 3, word 4

It may be understood by Adalo:
Text 1: Word 1
Text 2: word 2, word 3, word 4
Text1: Word 1, word 2
Text2: word 3, word 4
Text1: Word 1, word 2, word 3
Text2: word 4

You need to create different rows for each word?

In my example with these 4 words and commas. If I have only 2 text fields, how Adalo will understand the csv :

Word 1, word 2, word 3, word 4 ?

And how to change its understanding if I need to. For example if Adalo use the first coma to separate the field 1 and the field 2 (so field 1 would be « word 1 » and field 2 would be « word 2, word 3, word 4 ») but I wanted the field 1 is « word 1, word 2 » and the field 2 is « word 3, word 4 ».

Is it clear?

@dilon_perera do you understand the problem ?

My example was a bit tricky to understand. Let’s simplify.

If I want to create with CSV in 1 text field this sentence:
“Hello, I’m fine”.

How to do it with the comma in my sentence ?

I think then you need to cut them down like that in your CSV and then upload it on Adalo!

You mean add the comma after Hello too? It doesn’t add?

Yes I want to add the comma too.

I want my text field to be:
« hello, I am fine »

Adalo understands the comma after « Hello » like the end of the field. And so « I am fine » is another field.
How to tell Adalo it’s not a comma for separation but it’s the same field ?

Once you add hello,I am fine in the CSV and upload it on Adalo you don’t get the comma? Is it possible to explain this from a video showing the CSV and the setup?

I am stupid.
I used CSV without " ". It worked but with " " it solved my comma problem.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.