Current data not found

I’m putting information from the database into the home list and linking to details from there, but I can’t see the Current bata.

By the way, I’m Japanese and my English is not very good.
I don’t know if I’m communicating well, but I’d appreciate it if you could answer me.

1 Like

I got the same problem, earlier this week everything worked fine but now it crashed :frowning:

Hey! That’s super strange that on the available data part of your screen that there’s nothing there. Could you send me the link to your app so I can send it to the dev team to look at? (No one else will be able to view the page except for the Adalo team.)

Hey @David,

I am just now running into this exact issue.

Here is a link to it if that will help. https://app.adalo.com/apps/fdb9d347-f4e4-45e2-8adb-ca6d18676d7d/screens

The weirdest part is the current components on screen using the “current X” data are still working appropriately, but I can’t see the data or use it in new components.

Which screen on this app? (Sorry you’ve got so many screens!)

hahahaha very fair. :laughing: I am noticing it on the Trip detail screen. “Current Trip” is not available and not being sent when you link out via action from this screen. But you can clearly see it is all working on that screen except for the messaging.

Thanks for getting us the exact screen. Having the dev team look at this now. Definitely a bug there. :see_no_evil:

Thank you, David! Looking forward to seeing this resolved. :slight_smile:

1 Like

Hey @David,

Do you have a timeline that you could share on this item being addressed and possibly fixed? I am trying to sort out a few other things on that page and want to prioritize other tasks accordingly depending on that timeline.

Thanks again!

1 Like

Hello! @David

Actually, I have solved this problem.
If you create a new page, you can receive current data.

A Japanese friend of mine did the same thing with the above method.

I love adalo and use it every day! More features would be great.
I’ll always believe in you! !

スクリーンショット 2020-06-22 12.20.23|690x343

1 Like

Hey @David, the same thing, Current data is not passed to the next screen. I noticed this bug on Friday. If I create a new Screen and link it, everything works as it should…but it is not an option for existing screens.

1 Like

I always see this bug. There’s a trick for this though.
The bug happens when you have interlinks : a screen being shared by logged in user and a list from other collection.

This will drop data and you cannot pass the Current data coming from a list.

It is hard to explain it :smile: but I have a workaround for this:

  1. Make a blank screen and put your list on that screen, link it to a blank new screen call it View Screen.
  2. On that new View Screen, do what you need to do add the image, text with dynamic texts etc.
  3. Now, copy those elements and paste it to the screen where you really need to have the Current data.
  4. You might need to re-path/relink the elements BUT the Current data is now selectable.
1 Like

Yep, it’s an option…but if you have a lot of screens and connections…it’s a headache to relink all connections…

1 Like

I have not been able to fix this at all, even with duplicating the screen and relinking everything to and from it. Definitely an annoying bug.

Has anyone found a solution to this yet? Still struggling to get my current item data back for use in a screen

Do you have a screenshot or something to show your case?

I just figured it out. I had to remove every single link to and from the screen, then added them back one by one before finding out that one of the actions linking back into the screen was breaking it. I am still not entirely sure why it breaks it. But I finally got this solved and can continue building. :raised_hands:

I shared a solution a couple of days back - refresh browser after adding a new screen (either via link -> new screen, or via editor directly).

But its definitely a bug since last Friday.

1 Like

I’m running into the same issue. It’s confusing and unbelievably frustrating. I have a data collection “My Sprouts” and I used “Current My Sprout Name” in one text field. But if I create a new text field, I cannot access the “Current My Sprout” as a choice. How is that possible?

Also, I tried clearing cache, refreshing, deleting links between screens and re-adding them. No luck.