Custom Action doesn't work


I’ve created Custom Action and it worked properly in “test mode” and in Postman.

But when i’ve tried to use it with real data - it didn’t perform.

I can’ figure out what to do =(

Custom actions are only available in paid version.

I tried CA during the Integration Pack Trial. And most of CA worked properly. Only this one failed =(

Now i have paid version, but it isn’t working =(

Hi Oleg @Oleg_Meshkov,

There is some inconsistency in your custom action setup.

Short path to explore: try to check how “1 Number” and “Phone_Number_Field” are being sent to a custom action (3rd screenshot). If you click on the pen right to “1 Number” and “Phone_Number_Field” respectively, does it allow you to set number format? If yes, change it to “None” and try if it works.

Longer path: I suspect that the problem is that numbers are being passed with commas (,) into the custom action. You can see the payload in the Network tab in Browser dev tools.

Also, if you’re passing numbers - no need for quotes in JSON:
{“phone”:PHONE_NUMBER}, not {“phone”:“PHONE_NUMBER”}.

By the way I’d recommend contacting @oper2k about YClients - he had spent a lot of time trying to make it work :slight_smile:


1 Like

Victor, thank you for response!

I tried different ways to solve the problem.

  1. Changing the format doesn’t affect an error. I even tried to use CA with “hardcoded” values. Doesn’t work.

  2. I thought changing commas will help, but … nope. Although both ways works properly in Test mode )

  3. The problem on Adalo site, not on YClients.
    Bcs everything works properly in Postman =(

Hi @Oleg_Meshkov,

Then the only thing left is to see what’s being sent to Adalo backend (Network console) and check if the info is correct there. If the request is the same like in Postman, but Heroku still returns error - you can only submit a ticket (Submit a Support Ticket).

I’m not talking about problem on YClients side. After setting up authentication there, you might face some problems getting the schedules and times - YClients API is quite specific and not very compatible with Adalo. That’s why I recommended to contact @oper2k.


Hi, @Victor
I can’t say anything right now.

It’s just started to work. And the most thing that making me angry is that i don’t understand WHY!!!
I’ve tried to repeat everything… and it works anyway: with/without commas in JSON, with ANY format of values…

That’s just a MIRACLE!!!
And it’s very annoying…