Custom Action not sending test?

I’m trying to create a custom action on a form submit button (It’s the second action of the button). I’ve followed the tutorial to set up a webhook in Zapier exactly. When I try to test the action in Adalo, nothing happens. I click the button and it just spins forever.

Am I doing something wrong? How do I fix this?

When you set your zapier webhook, have you tested it using this button? If you haven’t, I would recommand to reset your webhook and send data to zapier for validation using your button / custom action.

That’s actually what I’m talking about, the test while setting up the custom action is not doing anything. Just a spinning circle.

Weird… I’ve set up a zapier webhook no later that few hours ago.

In your custom action, you set “create” to post your data to the webhook? And your json is OK?

Hey @jasondupree I’ve been having the same issue. I gave up on Zapier a few days ago and tested Integromat today. All the tests were firing just fine, but upon live implementation using my data, nothing happens. Integromat has no record of any action taking place. Here’s a video:

Yes. So I actually tried it with just a button. Looks like maybe it won’t work on the premade form submit button. This is mentioned in the help article (, but it also said the workaround was making it not be the first action.

So I’ll just make the form with inputs instead.

This is actually very interesting. Thanks for sharing this. Have you confirmed this?

I set it up again to see if I would see the same problem. It is actually working now. The 3rd step test in the custom action set up now completes almost immediately. It may have been a temporary issue (Though I was trying for about 2 hours).

@jasondupree still not working for me. Do you happen to see anything in the video above that concerns you as to why this isn’t functioning?

I did notice (after I got it working) that when I used an input that required a relationship Zapier didn’t receive the webhook at all.

So I could have inputs like Name and Email, which are just simple text and it worked. But when I added an input for a relationship (like another user), it wouldn’t work at all. It may be that using a relationship messes up the formatting of the JSON.

My goal was to use this form to immediately add a new user. Since the above issue makes this impossible, I’m instead using a form to add a record in another collection, and using THAT as the trigger to add a new user.

Downside is that there is up to a 2 minute delay between adding the user and the user showing up in the collection.

I hope that helps troubleshoot your issue.

Good troubleshooting info, thank you! I’ve also noticed that the date is sent as “a few seconds ago” relative format instead of the UTC timestamp most other services need to pull in dates.

I’m also having an issue with the Custom Action test. I’ve set up other Custom Actions successfully, yet this time, I’m stalled with the spinning circle on the Run Test button. :confounded: I’m sending two text properties, so nothing particularly complex.

Has anyone else continued to have this issue? Wondering if this is a bug?

I also receive a 400 / error request when calling the Sendinblue API to create a campaign. And to be honest, I don’t understand why as I also tried to call the update method of the external collection (not a custom action) without using any variable, only hard-coded value.

Very difficult to debug as far as we have no debug console, inspect the chrome dev tools where I got the error notif but nothing relevant for debugging purpose.

@Ben @jeremy has there been any progress on the custom action issues?I posted a loom video about webhooks and custom actions earlier in this thread.

Hi, my custom action with the zapier webhook still doesn’t work…
When I test it, no issue. But when I click on the button which have to send data to a zapier URL, my zap doesn’t notice anything…
Anyone have an update ?
Thank u

Any updates on this? I am having the same issue with my custom action and Zapier Catch Hook.

Hi guys,

Has anyone found a fix for this?

Im running into the same issue with Integromat. Im sending the email of the user to a webhook but when I try to test request it just spins forever

When I created the custom action initially it worked perfectly, I came back to Adalo a couple of days later to test my app again and it had stopprd working.

I tried deleting the action entirely to create it again but now I can’t even add it back cuz it just keeps spinning.

I have also tried this in Postman and it works perfectly.

I would really appreciate any help I can get. Thanks

Hi Tami, just to let you know that we’re tracking the issue and should be back soon with some updates. Thank you for sharing and waiting.

1 Like

This should be fixed by now. Please let me know if you still run into some issues.

1 Like