Custom Filter not working


I am having an issue trying to filter a list with a custom filter.

I have two databases:
One named Users. it has a numeric field called cleanerid and for this example it has a value of 10.
The other one is called Zap-api-appointment. In which i have another numeric field called staff_id, also with a value of 10.

I am trying to filter a list where the cleanerid = the staffid. Both the staff id and the cleaner id are a number.

When i run the app the list comes back empty, even-though there are matching results.

Why is this not working? One id has the same value as the other one.

si, parece todo cierto - have you tried not to use the “Logged in” mode ?
maybe just for test, testing the “cleanerId” directly without being logged would work.
otherwise you d have to log in by going through the login screens then and make sure that as the logged user you are really using the ID #10 …(and not some other #Id numbers.)

Also, it may be possible that the current user data are not available at that moment. It is the case if your screen with the list is just after the log in screen. In this case, add an intermediate screen between the log in screen and the screen with the list. For this screen / workaround to be as transparent as possible for your users, add an action at screen level : “when a user visits this screen…” => link to screen ( the screen with the list).

Thank you very much to both for your help and time.
I did both of your suggestions. I am not sure which one did it, but i was able to filter the list.

1 Like

@diego Cool… !
@ChristopheHK I have seen the same work around in some other Topics…would it be that traffic back from servers can sometimes be “too slow” (slower than a change on a device) after some events ?

Hi, How did you solve?
I too am experiencing the same problems

1 Like