Lists don't work right

I have a list of users with some filters but it doesn’t show me any results, suddenly if I remove one of the filters it shows me data but they are not correct, has anyone detected a problem with the lists?


Hi Enrique,

I checked my app and works normal. Does these filters worked before?

Thank you

Yes, it has always worked. I have found the problem, one of the filters was if a numeric field is empty, it always worked fine, now I have put a zero in that field and the filter interprets it as empty…
@anon78309838 you should check this.

Great, thanks!
I have a question about the content of this topic.

The list problem you are experiencing is that when you specify “empty” in the custom filter, it does not work (all records are displayed)?

I am also suffering from a bug in the list and would appreciate it if you could let me know.

Yes, that’s correct. I thought it was already solved… try putting a zero in the registry field and see if it works.
Thank you.
Your answer is very helpful in proving that the problem has occurred.

As you said, I think the bug is fixed now.

However, I have lost my data due to this bug.
I had set up an action where only records with a specific field empty were deleted due to a countdown timer I set up in the list, but all the records showed up and all the records disappeared.

The Adalo team told me “We can’t reproduce this problem, so we can’t recover the data.”
So, your testimony is very helpful.

Thank you very much.

The problem in the listing you commented “This is a known bug being worked on right now.” is it the same as the following?

“I am trying to show records where a certain field is empty by a custom filter, but all records are shown.”

Hey @anon78309838 , this is happening again…