Date Filters dont work

Hello guys in my apps date and time Filters are not working, the hour already shift at USA?

Anyone with same issue?

I repórted 3 days ago

I raised a similar issue with support where my date formats were displaying correct in the database but in the wrong format when I previewed the app. I raised the issue on 17th August and got the below reply from Ben in support:

“Thanks for reaching out and I am sorry you are facing this issue.There is a currently known bug that affects some uses of the Date fields in other timezones. We have a fix for this in our testing queue, and expect it be begin testing in the next 1-3 weeks. I have added you to our notify list for updates as we deploy this fix!”

I still haven’t had a reply and sent a chaser email a few days ago…


This is very interesting timing. I was just beginning to respond to our tickets related to this. (@Ash1 I am not seeing your follow up email in our thread?)

The fix for this was just released today, in the last couple hours. Can you do some additional testing in your apps and let me know what you are still seeing if you are still having problems?

One more note. For Native apps, this will require new builds to be published.

Thanks for the reply @ben1 but I have just replied to your email again as this bug fix hasn’t worked for my issue unfortunately.

I still have an EU date format in my database which is then displayed in an American date format in preview with no way to change it from what I can see.

Hello, thanks for the fast answer!

I already checked my app and nothing change.

In my case, I changed the date filter from between - beginning of today and tomorrow, to after 1 day ago. and returned to work.~

This is a old fix that i discover to work so i rollback to this.

i’m in Portugal.

But yeah this is good for me, and it’s solved in my view.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.