Deck Swiper Issue

Hi guys,

I am building a feature using Deck Swiper,

The problem i am having is that when i make the deck swiper display Items, As i swipe, the current item is not updating. for instance:

  • I have a click action that should link to the current product page.

When clicking on it, it is taking me to the same product page regardless the product i click on. Its always the same product page which is usually the first item on the deck swiper.

I believe this is a bug on this feature, but before i submit the bug, i was hoping some of you could explain if this is the how the working mechanism should react… as you flip through items… the item you click on should also be updated. It would only make sense for it to be that way in my opinion.

Appreciate your replies,



Hi @jmb2021,

I think there’s a bug with the Marketplace Deck Swiper. If I have a update action to add the users to a many to many rel property ( following and followers ) it doesn’t add all users and adds sometimes 2 users ,1 user and sometimes working well :joy: ( not sure if other makers facing this same issue )

I think best is to Submit a Support Ticket and Adalo Team and the component developer ( Minimum Studio ) will solve this issue together! Or I think you can contact Minimum Studio.

Did you tried the Pragmaflow Deck Swiper? : Guys Check This Out!

Thank you

1 Like

hi, yes i have tried the pragma flows deck swiper, and it does work better, but still sometimes goes to the wrong item when it gets clicked on. which is unfortunate! lol 50% of the times its taking me to a different item .

Hopefully they fix this soon,

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.