Delete DB record doesn't delete

Hi team,
Not sure if this is a bug or a “soft delete” feature, but.

Example:
I have a button to delete logged in user.
I have 4 users.
I click the button - user should be deleted. In fact, I can’t log as the user anymore, which is expected.
I also see 3 user records mentioned in my user collection, but inside the collection, there are still 4 users.

What should I do to delete the user irrevocably?

Thx!

Hi @bentsajulia,

That’s interesting. Tried to do this in my test app, delete user worked (I couldn’t log in with the same username after deletion).
But user record was visible in the database like in your case.
It seems that DB in builder interface is somehow cached - after I reloaded the interface, this record has disappeared.

Leaving this to @Colin - may be he can provide more insights.

What delete sequence did you use, by the way?

Best, Victor

1 Like

Hi @Victor,
Thank you for the insights!
Indeed, when I reloaded app deleted record disappeared. So agree- it looks like the caching issue.

I would say it’s not a problem for the moment at all, since my app is not on PROD and I don’t have any active users.
But, as far as I know, it’s important for AppStore to have a way for the users to delete their own profile and clear all data, so I’m just trying to understand wouldn’t it be a ‘security’ issue.

The sequence is below:

  1. Create a button with “Delete logged in user” action
  2. Go to preview
  3. Log in as a user
  4. Click the button
1 Like

It seems this connection is not asynchronous and therefore requires a refresh to update the data there.

I agree it’s not the best UX but not a bug either. I can make an internal note on this to fix in the future.

1 Like

Hi @Colin
Agree. I just wanted to doublecheck that data is deleted.
If it takes time or refresh to delete I’m ok.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.