Unable to delete records

I have been trying to delete records for over an hour now and i am unable to. I click on delete but the records are all still there.

@Colin

Hi @Tami,

After you hit the Delete button did you try to viewing again after reloading your browser?

Thank you

Yes I did. I even logged out twice and cleared my browser.

That’s weird! By click on delete you mean a button has the delete action on your app or the delete button after you select record/records on that collection view in your database? I don’t see any issues with deleting records on my side! Check this post posted by Colin : Delete DB record doesn't delete - #4 by Colin

If after reloading the tab , after clearing your cache and still not work I suggest to Submit a Support Ticket!

Yeah I’m trying to delete from the database. Apparently it’s only the user records I can’t delete. I tried creating a new collection and deleting a record and it worked but I can’t delete a user’s record.

My guess is it’s an Adalo issue that will resolve. I’ve had many situations like this over the last couple days, even today I tried to delete a record and it simply would not. Others include builds failing and collections not responding for 15 minutes sporadically.

My 2 Cents: Can also verify that, Delete doesn’t remove a record from the database. I have a couple lists that users can add to or delete as they want. When deleted the user no longer sees the record in the app but the record remains in the database. This seems to be fouling up other things in the app as well. I have a list that is allowed to display 8 records. The first 5 are defaults that cannot be deleted. If the user adds three items, no problem but if they delete one, then add another one the total allowed list count will now become seven. What seems to be happening is though a deleted item disappears from view it doesn’t disappear from the Database and is still counted, something that not only shows up in allowed list count but, potentially in calculations like RAND function that use COUNT as part of the equation.

Yes there have been some very annoying bugs over the last couple of days and unfortunately submitting a ticket doesn’t help cuz it literally takes a day to get a response and then another 24 hours for another response.