Does not open the ADALO edit

Hello, I haven’t been able to access ADALO for 3 days, and I’m wasting a lot of time…

every time I log in I get frozen like this, loading and the processor makes a lot of noise… It’s the only page that does this to me, when I go into design programs like corel or adobe, or programs to make videos like filmora… NEVER DELAY and it doesn’t make this noise…

Obviously when I use ADALO the design or video programs or whatever are closed

Why is Adam like this? any solution?

I can see you are using Chrome.

What other browsers have you tried? I use Brave and it works great.

I only use google chrome… which do you recommend? To download it

I use Brave.

But test others as well. I’ve heard Firefox also works well.

1 Like

Great, I’m going to try it, because I deleted history, cookies, passed the antivirus and everything… I even did the Indian dance hahahaha and still nothing!

1 Like

Have you tried logging out of your Adalo account and logging back in?

yes… i already tried everything… even deleting cookies and everything… now download firefox and it doesn’t load either… facebook, youtube, zoom, google and everything works fine just adalo it gives me many problems to enter

How many screens does your app have? Does it have a lot records in the database? I would suggest downloading Brave as @charleshope said.

It’s just that ADALO doesn’t open directly for me… I go to Adalo, I log in and that’s it. I can’t go to any app to start working… there I try with brave

How did it go with Brave? Did you also try Firefox?

After 3 days I was able to enter… there it loads me from chrome without problems… I already downloaded the other two just in case!


Hey, for speed of editing and panning around Firefox is very fast. There’s other things a little buggy though. Another possible solution is use a VPN (huge difference for me based in Ireland). When your app grows to above 50+ screens a VPN will make a big difference (VPN Location in US). I have apps that simply won’t load, or take ages unless I use a VPN.

Firefox + US VPN = :fire:


How good this … I’ll put it into practice!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.