Error In Signup Screen

When I try to do a test signup in the Preview Screen I keep getting a pop-up message that says “User email already exists,” and when I click out of it and go to the User collection a blank record of that user is created. This just started happening today. How do I fix this?

Hi @LaoEntrepreneur,

Do you try to sign up with username, not email?
If yes, in these posts and links you might find some useful info:

Best,
Victor

Hi Victor. First and foremost, OMG, thank you so much for all your tutorials. You’re a Godsend. I especially love the multiple intro screens. It totally fits my app. To answer your question, no I sign up with an email. But every time I got to a signup screen I get a “User email already exists” pop up error and I have to close out of it and try to sign up it gives me this error “Invalid Email or Password…Please double-check the info you provided and try again.” So it won’t let the user go past the signup screen. The crazy thing is a blank record is added to the User collection and after a while it populates with the info and it’s not blank anymore. I just wanna fix it so that User don’t leave thinking they couldn’t sign up. Any idea what is going on? Such a weird problem. It only started happening today.

Hi @LaoEntrepreneur,

Thanks, glad I could help with my tutorials!

As for your problem: that’s weird. Just out of curiosity - which action do you use on sign-up?
“Sign up user” or “Create user”? If you use the latter - that might be a cause of the problem.

Best,
Victor

1 Like

Hi Victor. I did in fact use Creat User as opposed to Sign Up User and I changed it but it’s still the same problem. Also in the magic text somehow the field “Username” is linked to Username field in the User collections column. I’m still trying to figure it out. BTW, wasn’t that your tutorial about creating the Admin and User sign up screens? If so, I followed your tutorial and created the Interim screen thing but then once I did that it just takes it to those screens and I can’t go back to the home screen. How do you fix that? I’d since made the Home Screen the Homescreen now as opposed to making the Interim screen the home screen.

I think I found the mistake now. The “Signup” button I didn’t connect the fields of the action to the fields of the User collection with the magic text thingy so maybe that’s why i created a blank record because there was nothing connected back to the record. My bad. LOL.

1 Like

Still didn’t do it. I corrected the Action for the signup screen and the action for the signup button but still the same error and still creating blank records. Sigh.

@LaoEntrepreneur @Colin This is happening to me as well (and maybe to others?) as of today.

I didn’t have that issue before and I haven’t changed my sign up flow at all, so that points to an issue on the Adalo side.

For me, it does create the user and populates the info but doesn’t log the user in, it just stays on the sign up screen. The logical next action for the user is to press again the 'Sign up" button, which gives the “email already exists” error. But if you try to login, you can. It’s just that no new users will actually try that.

Thank for letting me know. At least I’m not scratching head not knowing what’s going on. I thought it was weird and was thinking that it may be an Adalo issue. Yeah, it sometimes works and sometimes doesn’t work for me. I had a friend of mine signup and he got the same issue but then he kept hitting signup and it let him in. Let’s hope they fix this soon. OMG. How would this be if we were to publish these apps on the App Store and Google Play Store.

Hi @LaoEntrepreneur,

With “Create user” it doesn’t work correctly.

As for your question reg. Admin and User screens - it’s a bit different question. The reason I assign the “Interim” screen as a Home screen is the following. Let’s imagine user logged in as Admin, then closed the app. After some time the same user opens the app. Where he/she should go?
The answer is, that he/she should arrive to this “Interim home” screen, which will then direct the user to correct screen (in this case - Admin).

@jnestour thanks for the heads up! For my test app new signup works, but whole app builder was very unstable about 1-2 hrs ago.

Please DM me a link to your apps if you are still experiencing this issue. There is a known bug that causes these errors but we have never been able to reproduce it.

I DM’d you my app but just in case here it is: https://app.adalo.com/apps/51e3e7ab-85b9-4cff-b3a7-61a623ec7163/screens/preview

Also, how can i set the preview link to a custom domain? I set my custom domain in the settings to app.asianbiz.tech and add a DNS record to app.asianbiz.tech and it even says it’s successful when verified but the preview link still has Adalo’s name attached to it.

Thanks,
Sinakhone

Are you still experiencing issues here? We released a couple fixes related to this recently.

Nope. I deleted that app and recreated a new one. But, I’m having another issue where I can’t see my preview inside the editor. I have to use my phone to see the update to the work that Im doing and it’s cumbersome as i have to redownload the app everytime.

What happens when you use the previewer?

It gets stuck on the loading screen. It just started happening after I installed the top left icon as a drop down menu for Account” for things like user profile, orders, past orders, payment, help, etc.

I just checked if I experience the same problem on your app but it loads fine for me in the previewer.

What browser are you using?

Chrome. That’s weird cuz it just started happening. I’ll try to sign in on Safari. Thanks for conforming for me.

I’m also on chrome. I tested in Firefox, Opera and Brave and it worked on all of them.

I cleared my cookies and it works now. Thanks!