Getting error in Preview, Error getting App

I am getting error “Error getting app” whenever i try to Preview my build and in some apps, it gives me an error “App not found”.

Can someone please Help.


Hey there, I’m guessing you didn’t set a Home or Welcome screen in your app. Make sure you have set the first screen you want your users to see when they open the app for the first time.

Thanks Vance for the quick reply.
I have setup both pages Home & Welcome but still getting the same error. Any other suggestions,

I would double check all actions to see if you redirect logged in user to a screen that no longer exists

Thanks Edward for revert.
But I even tried creating new app from the Adalo template but it is giving me the same error when I just preview it, without any changes.
So it looks like nothing in any app but somewhere else.

I’m getting the same error, but it’s intermittent. Sometimes app runs, sometimes I just get the error… until yesterday everything was working fine.

1 Like

Got the same error! Plus the changes that I made are not visible in the preview (of it works)

Everything was fine till this morning

Same here. Seems to be a general problem with the previewer i guess?

1 Like

I am getting the same error! Yesterday and today I have been experiencing extremely slow actions and seeing action errors where there shouldn’t be, and preview failing altogether

I submitted a ticket it is really affecting me right now. Has anyone else submitted a ticket? and heard back? To me it happened with all my apps in all my accounts at once.

It is now working for me again, but the changes I made aren’t working. It’s not updating anymore:(

The same error. :disappointed_relieved:

Having the same issue - just as I was about to demo to Investors :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth: :face_with_symbols_over_mouth:

Hey Everyone,

I wanted to apologize for the issue this morning and also not getting back to you on this post sooner. There was a short intermittent issue with PWAs (which would also be the Previewer in this case) where they weren’t loading sometimes. It was a little challenging to track down because it wasn’t all apps and it was not happening every time the app was loaded, but the issue was resolved about 3.5 hours ago. We’ve also implemented new alerts for this type of error moving forward on our end.

If you’re still having issues please let us know!


Hello, I would like to point out that the webapp isn’t responsive and not great! UIs overlapping, and more!

Dear David,

I am still having the same issue.
I even tried creating new app using sample Adalo Templates.
Can you please help.


Hi David,

The problem still exists. The app cannot be found in the preview and does not work in the share on the mobile. Everything was working before, so it is not a problem with the app itself…


The issue seems to have reappeared a short time ago. I am currently monitoring the situation and contacting the team about it.

Same here, preview is not working most of the time.
Very buggy right now, sometimes comes up.

Returns APP NOT FOUND error.

Again same problem !! Since yesterday preview does not work it goes on in fits and starts … “App Not found”.