Google API Location Troubleshooting

I’m trying to get Adalo’s new Location feature. After getting the embedded Google Map to work, I thought I’d figured it out, but the location search seems to be requiring something different.

Here’s a summary of my Google Cloud account:

  • Active API project with valid Billing
  • Enabled APIs (see below)
  • Website Restrictions setups for the API (see below)

…But I’m still missing something. Any ideas?

Previewer Error

Enabled APIs

API Restrictions

I recall having to actually remove the website restrictions to get mine to work. I think I initially got the same error message you’re seeing now. Have you tried removing your restrictions to see if it works? If thats the case, then there is probably a better answer or fix that needs to be explained, since we should be able to set restrictions. Once I got mine to work, I didn’t raise any questions about website restrictions and them leading to the component not working…I just accepted it.

Gotcha. The errors persist, but I have removed the web restrictions and will keep those off until this issue is resolved. Thx for the input.

Hey there @wes

You’re missing the Places API

1 Like

Boom!! It works. Thanks for the help.

1 Like

Happy to help :sunglasses:

I’ve also broadcasted a message on our community leaders channel to request a revision to the help documentation so that the Places API can be added to the links of APIs to enable.

Nicely added Flawless :muscle:

Some makers forgot to enable this API! See another two topics : Location property field throws this error: This API project is not authorized to use this API , Map API error (Location Data is Not Available)

Maybe highlighting them in the Docs to make them required will be a good idea! :bulb:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.