Location data not available

I’m getting “location data not available” at the bottom of my screen suddenly.

All the API’s are active and the billing account is up to date on Google. is there something I’m missing? Did my activity put me in a higher tier that I’m not seeing for some reason?

Hi @deetee,

Is it possible to add a full screenshot of that message preview?

Thank you

I will do that the next time it happens.

Sadly (or not to sadly), it’s not happening right now. That makes me wonder if it was just a glitch happening last night. I’m hoping others will come forward and share similar experiences.

I change my answer. I can’t do a full screenshot, but I can take a screengrab of just that portion of the preview. See below.

Screenshot 2022-06-13 083241

Now that I think about it… is this referring to the location data of my device? I see this message on the laptop preview, but 'm not seeing the error on the mobile device. If it’s this simple, then maybe the error is too vague. IF that’s the case, the error should say “Device Location is not available”. Is Adalo throwing this error or is my browser doing it?

Can someone clarify?

For the record, I just opened into a different browser on my same computer. It prompted me to grant permission for the web to use my location. I hit allow… and then I saw the error message again.

I’ll look into this on my laptop side, but in the meantime, it would be helpful to know who is throwing this error message.

Will check this and let you know. New to me :eyes:

1 Like

Im getting the same error as well.

@deetee I tried the previewer on my mobile and it doesn’t show the error message as well but I think some actions won’t be executed. Cause I had an item counter on the page but it didn’t work.

For me also it happens now when I click allow when the permission asked in browser.

Monica from Adalo Team said that this seems a problem if you don’t allow location permissions. And I sent my App URL to her and Monica said that I will look at this and let you know! Waiting for a reply from her!

1 Like

I was experiencing the same issue. Checked today, and location works again. I did create a new api key and updated the info on Adalos side. Anybody else find a solution?

Hi @cball,

Welcome to the community :partying_face:

Are you seeing this only when previewing the app in desktop and not in mobile?

Can you remember in your app that this message displayed after clicking what action?

Thank you

The messaged displayed on mobile when clicking into the location search. It is no longer occurring on mobile or desktop, but I did not check desktop when it was not working.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.