Google Login Issue in Android

I followed the instructions in the below article to add Google Login to both Web Client and Android app: Sign in with Google - Adalo Resources

It worked fine on the web client, but it doesn’t login the user from the Android app. It just opens the pop-up to select the google account, but when I select the google account and go to any screen in the app, it doesn’t detect that the user is logged-in.

1 Like

This has been reported multiple times as a problem. One user said they fixed it and in my limited testing, it seemed to be working. I tested it and it was working just checked and it’s broken again.

I am still trying to reproduce this issue. Which app are you experiencing this on?

What device are you testing on?

It appears it is working now. I am doing more testing. Thanks!

hello I have problems with google authentication in android. it works correctly in the web version. galaxy note 8

This is still a bug Colin. Also on an application I’m developing for a client there is this problem.

When published, will show you the app if needed.

1 Like

Been having the same problem with two of my apps. It doesn’t work in preview mode, or on my phone.
Exactly the same thing happens. Google login pops up, once you log in, then it goes back to the sign up sheet without recording the user.


Iphone, preview and computer browser.

Also having the same problem here.

Same issue here. Please fix :slight_smile:

Yes, same issue here, Google sign in will sign the user up but will not also log them in directly after signup, so they are sent back to whatever screen is the Welcome screen, forcing them to login again with the info they just entered.

We are still having trouble logging into Google

When user pushes the button in Android build than nothing happens, every thing was done as in the tutorial…

Me too having this issue, I’ve done all possible credential settings, it’s working in preview but in app or pwa getting authentication error

Same problem. Does anyone know if this is being actively worked on?

I sorted out adding same web client id to iOS client Id, solved the issue.

Hi Guys.
I am having the same problems, authentication works fine in Preview but does not work in Android.
Have any of you find solution to this?

Having the same issue with my Android app, has anyone found a way to fix this?
Yet Google sign in works fine on PWA & iOS.

Hi everyone :grinning:. I have the same problem only on Android. Have any of you find solution?

Seems like the Google Support team has found the issue for my case. Here was their answer:

As you have enrolled your app into Google App Signing. Please make sure to use certificate fingerprint from " App signing key certificate " section for the implementation of your app / API.

You can find it by navigating to Play App Signing:
Play Console >>
Click on your app >>
Setup >>
App signing
I hope this helps! If you have any further questions regards to Play Console, please let me know.

So on Google Cloud Platform I updated my app’s OAuth 2.0 Client ID for Android with the SHA-1 certificate fingerprint I found on Google Play Console and it works fine for me now :pray:t4:

Hope this helps,

1 Like