Several problems with an Android


I am opening a ticket here because I have tried several ways, but nothing works …

My tests are all conclusive on iOS, but I am having issues with Android.

I can’t get “Google Sign-In” to work on Android only, it works fine on web and iOS.

On an Android, this opens the window for me to select the Google account to connect with, once selected and logged in, the window closes and nothing happens.

I read on the forum someone who indicates that it is necessary to put the SHA-1 key of the play store developer account on the google console, except that I cannot register it because it is already present on FireBase "Entity already exists ”.

Does anyone have the solution?

Also, I am unable to try a “Digital Purchase” purchase at the Android level, while on the iOS side, everything works correctly …

On Android, when I click on the button it opens an error “Could not buy the requested item” …

Thank you in advance,
Best regards

para que funcione de manera nativa en android el acceso desde google tiene que tener la clave SHA-1 en firebase y dar de alta el acceso desde ahi. no en el rpoyecto de google como se indica en la ayuda de adalo

Hello leguizamonmax,

Thanks for your return.

I tried to remove the “Android” access service from the Google Console side and put the SHA-1 key on the Firebase side.

I updated the google-services.json file

Nothing changes … It still does not work on Android.
Do you have a solution to help me?

Thank you


Nobody has a solution for debugging?

Nobody responds to Adalo support tickets …

It’s really weird the support here. Especially for a paid service.

Too bad, it’s a good service.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.