Sign in with Google on Android - does not work

Hi

The Google Sign In option does not work

when i download the apk file from adalo and install it directly on my android phone, this option works,
also this work on PWA

but when i do a release update on google play, it stops working

What could be the problem ?

1 Like

the problem solved
in FireBase β†’ Authentication β†’ Sign-in method β†’ Enable Google

I tried that and I still have an issue. Did you have to do a new build with a new config file?

no new build needs,
one more thing:
i chenged this option: Console Cloud Platform β†’ credentials β†’ your andoird client β†’ SHA-1 certificate fingerprint
to
Google play Console β†’ Setup β†’ App integrity β†’ App signing key certificate β†’ SHA-1 certificate fingerprint
instead of fingerprint in adalo help

But it still doesn’t work great. The user has to press the Google Sign button twice, the first time to select an account, the second time to move on (

Thank you. I think I tried both suggestions and it still doesn’t work.

what about your status of OAuth consent screen on console.cloud.google.com ?
is it In production ?

Update. @geullaideo I went through the steps again and it is working (Sign-in with google) on both Apple and Android markets! same issue remains on the Apple market, it requires double-clicking. hopefully, Adalo would address that issue soon.

Glad to see you made it
Yeah, I hope adalo fixes it.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.