I don't see the changes for my PWA as I try Preview or Share

Hello.

Since around 2 weeks I don’t see the changes for my PWA as I try Preview or Share.
It cost me a lot of time to refresh over and over and to change the browsers hoping for a change. And if it is functional, it is random.
I stopped the work for the project many times because of this and I see that it is an issue for others too: Changes not applied to pwa
PWA does not load properly

Is there a solution for that? An explanation from Adalo?
Thank you.
Ionut

1 Like

I need an update on this from Adalo team…
I am now messing some correct functionalities as the preview is not updating…

Some people (me included) are having this issue. I’m also about to loose a customer if they don’t get it fixed soon (2nd customer I would loose due to bug)

1 Like

Yes, I understand you.
I have functions that are not shown and I believe that I have made a mistake and after hours of checking I realize that there was no error, it is the platform…
And I am in this situation since around 2 weeks.
It was very difficult to work like this.
I should be ready now, but…

1 Like

[UPDATE]
My PWA is full functional and back on track!
:partying_face:

//

This was only for some hours…

My app’s actions are still not working ;(
@ionutilie are all your actions working? Do you have custom actions too?

Hi @axme
No, I don’t have custom actions.
All others are ok now!

How did you fix the problem please ?

Hello @Fafa
I guess it was a misunderstanding from my side…
I checked the post as solution since the functions and preview started to work ok for my web app.
BUT it just happened without any action or fix from my side.
So it may be again in a few hours but for me now it is no more an issue…

1 Like

Funny…my WebApp previewer just started doing this…and it also started not saving any changes from the editor. This is fun… Glad you were able to get your fixed, hopefully the rest of us are next!

2 Likes

:roll_eyes:
I hope the platform will be ok again for the entire community asap…

1 Like

hi @Victor, would you maybe have some insight as to why it’s not working? Maybe it’s not on Adalo’s side…

I’m having trouble with my custom actions, actions and link screen transitions.
It’s only happening in one button but I can’t figure out what the problem is as it worked one time and then it stopped working. Here I walk you through it: https://vimeo.com/488950783/8ad0552476

It’s in the submit order screen

to me more precise:

  1. Twilio AWS: It’s a lambda function: It’s able to read what was selected in the multiple select and send over to AWS.
  2. Update User: it’s able to update the user by subtracting 1 to credit available (sometimes)
  3. Update Order: it has the randomizer on page loading and that’s able to update. It is not updating with the variants selected.
  4. LInk to a new screen: this is not working. The button stays loading and after loading it still stays on this same screen

1 Like

@axme that doesn’t look like the same issue in the post. I can tell you that when you have a list of actions as in your screen shot, if one fails, the rest after it will not run. You’ll need to fix your Square actions for sure.

1 Like

Thank you Jason, I did not know that!
I’ve tested the same without any custom actions and it’s still not working.

Hi @axme,

Well, from debug perspective, I could recommend start adding actions one-by-one from scratch and see where the failure occurs.
This is what I usually do…

Best,
Victor.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.