Image Source Not Letting Me Select Adalo Database

Hi Adalo community!

Has anyone had this issue before where they are trying to select an image source? I have an image list where I want the images to be from the Adalo database that records when users upload images. I can see the images are being added as records to my database but the actual image

Any help would be greatly appreciated!

Thank you!

Hi,

You do not see that option because your database relationship is many to many/one to many.

To connect the image please connect the list with that collection where you store all the images & then connect.

Current {yourCollectionName}>YourImagefieldName

Hi ishantanusrivastava,

Thank you for the response! How do I set the database relationship to be one-to-one instead of many to many/one to many?

Thank you,
Ashley

You add a property and choose the “relationship” then choose the 2nd option, which is many to many then click done! Tell me if you need any more help!

2 Likes

UPDATE: I was able to resolve this image source issue. Thank you all! I found it helping creating a new collection and following the same previous steps. I didn’t really do anything differently though I noticed that finally the image source was letting me choose the correct image from the database that corresponded with the one the user would upload.

Thanks, again everyone!!
:grinning:

If you want it to be one to one relation then select the first option in the relationship option. I really don’t know why the image button is greyed out. Try deleting the image property and adding it again.

Select the first option for the relationship:

1 Like

Thanks, James_App_Maker-it looks like it’s working now!!

1 Like