Issues with accessing data from related collections

I’m running into a confusing part of Adalo.

I have a collection called “Group” and another called “Topics”. In the “Topics” collection I have a field for Image (field type:image)

I plan on having 2 users in a “Group”

I have “Topics” related to Groups through a relationship (“Group” can have One Topic, Topics can be in multiple Groups)

I place an image on a page and try to get the source of the image from the database by choosing Database > Logged In User > Group > Topics but after that the field for Image in Topics doesn’t show up as an option.

Why would this be the case? I’m also trying to do the same thing with text for the name of the Topic in that Group and I run into the same problem. The choice for that field is just not there. Am I missing something or is this a known issue for Adalo?

Looking at that, I’m wondering if Topics would need to be associated with User too? As you are starting from the Logged in User?

I am starting with Logged in User. I tried associating the Topics to Users just now and I still have this issue. You can see in the attached screenshot it doesn’t give you option to get the Topic name of the topic image. I also tried the route of Logged In User > Group > Topics and the options for the Topic name (when editing a text field text) and or the Topic image show up.

What is also strange is that in the database option, Logged in User and Form Inputs are the only options. All fields below are grayed out.

Have you linked to that page from another page yet, like from a list or something. I think you have to specify just one item to pull the image from because currently it’s looking at all records for that user. Instead of going through Logged in user, you’ll need to look at Groups or Topics and filter based on the email equaling the Logged in user’s email.

1 Like

Yeah, you’ll need to have a list of topics either on that screen or on a previous one that links to is so that you can have access to Current Topic > Image in the Magic Text menu


Did you get this resolved?

I am having a similar issue:

I have two DB tables, that are many to many.

A User can be in many Groups
A Group can have many Users

When I load a specific Group onto a screen… I am not able to access the User data. All I seem to be able to access are the formula tools like Count, Sum etc…

On the group page, I have a list that is pulling in User data and filtered to Current Groups > Users

Any suggestions?

Hi Gavin, can you post some screenshots of your setup so we can better help in this problem?

This Works. Refer HERE.
It is happening as a specific property can be changed in a specific collection if two collections are interlinked.