JSON error when try to add multiple records

I wrote a custom action to add new records to the database. Please see the screenshot below.

Everything works fine if there is only one record but I got this error when I tried to add a second record.

I’m brand new to JSON. I tried to find more tutorials related to this issue, but they seemed more complicated to me. Please share how to add multiple records into DB with 1 Custom action.

Please help. :slight_smile:
Best regards,

I think you need to be adding one record at a time, rather than trying to add multiple in one custom action.

Hi @Toey,

Expanding @theadaloguy’s reply - you can’t add several records using Adalo API “POST” method as it is not supported by API.

Moreover, there is an error in your JSON - you need to have a comma after the first section. Tools like https://jsonlint.com/ could be very useful in JSON validation. But even if you corrected this - see above :slight_smile:

Another question is why would you want to add the records using a custom action instead of adding it using regular way, but I can imagine some cases when this is required :slight_smile:


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.