Link URL problems

https://calendar.google.com/calendar/render?action=TEMPLATE&dates=20210513T050213Z%2F20210514T050213Z&details=DESCRIPTIONNNNN&location=the%20shop&text=TEST%20EVENNT

The above link works correctly when you input it into the browser.

When using it from an Adalo button, Link → website, it does not carry the date to Google correctly.

Any ideas why this might be, or a solution?

Thanks!

One solution that works is making that long link into a TinyURL link, then it works from an Adalo button. But not really practical for what I need.

I’m using an ICS-URL and I have the same problem. In the TestFlight version of the app there’s a popup with “Could not load link”.

Do you have ICS link working on previewer? I am trying to use ICS links and having issues.

Yes, interestingly it works on previewer, but not on TestFlight.

I’ve noticed the same, also using a button inside the HTML renderer component.

Hi @theadaloguy,

Interesting question :slight_smile:

The problem lies within %2F in between the times
20210513T050213Z
20210514T050213Z

Short solution: to make it work, replace %2F with / (forward slash) in your External Link. Worked for me in the preview.

Longer explanation: seems that Adalo does URL encoding when working with external links. So, in browser link %2F transforms to “/”. But Adalo transforms it to %252F: it thinks that % should be encoded, encodes it to %25, and leaves 2F as it is.
You can copy and compare 2 addresses from address string in the browser and you’ll immediately notice the difference.

An interesting question is why Adalo doesn’t do the same with %20, and how this encoding of % could be avoided…

Best regards, Victor.

3 Likes

Victor, thank you so much!

1 Like

My pleasure, glad I could help :slight_smile:

Is it a similar problem with this link?

data:text/calendar;charset=utf8,BEGIN:VCALENDAR%0AVERSION:2.0%0ABEGIN:VEVENT%0ADTSTART:20210618T080000%0ADTEND:20210618T090000%0ASUMMARY:%F0%9F%8E%AFTitle%0ADESCRIPTION:Description%0AEND:VEVENT%0AEND:VCALENDAR%0A

A bit of a different problem. I’m actually just finishing up on a service right now to fix this.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.