Maps component - not working

I added google maps api to the app, but don’t see

  1. App asking location permission
  2. Not calling api

Will maps component work only on mobile app or even on Adalo canvas while developing ?

Thanks

Hi SnapVix,

Are you talking about the using the app on the Previewer?

Try opening the Adalo Previewer with Private Browser. I initially blocked location and my browser remembered this setting, but on Private Browser it works.

In my opinion, the geolocation works better on web previewer than I expected, but it’s not the same as location permissions for Android / iOS apps.

1 Like

A small question besides with the great information provided by Barrett!

Did you add the Location Permission action? : Getting the User's Location - Adalo Resources.

Or are you talking about the Map component Current Location setting?

image

1 Like

Thanks a lot Barrett, your suggestion really helped. I tried Edge browser in private mode and it worked. Appreciate your help.

Ravi | SnapVix

1 Like

Hi Dilon, yes I added it and got a prompt to approve. Thanks for your suggestion.

Ravi | SnapVix

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.