Netflix-style list within a list possible?

Hi, I’m trying to make a list within a list, similar to Netflix’s UI. Here’s my layout with an example picture

  • A horizontal list of movies, using the horizontal card list component.
  • A vertical list of movie categories, using the custom list component

What I want is to have a vertical list of movie categories. Within each category, there will be a horizontal list of movie titles from only that category. To do this, I set the filter in the horizontal list to dynamically pick the name of the current category and filter it in filterByFormula such as: {Movie category}=“Category name (magic text)”).

For some reason though, the filter cannot do so and only displays those movies which have no categories set. So I get the same list of non-categorized movies over and over in all the categories.

This doesn’t work with external collections. Has anyone tried to do anything similar and succeeded?

I have only been successfully using internal collections (Adalo’s database). Lists of Lists - Adalo Resources

Hi @AddyEdwin , so you are using Airtable, can you provide a printscreen of the formula?
first thing I see is {Movie category}=“Category name (magic text) ”) you are using “” instead of ‘’ in the formula.

Hello JL

Here’s my app preview: Demo (adalo.com)

Here’s the Airtable base I’m using: Airtable - Netflix demo
Two notes:

  • I created an extra formula field in the “Movies” table to convert the linked record in the Categories field into a text format
  • I kept one movie (The Notebook) uncategorized so that I can spot errors later.

.
When I create a single horizontal list for say romantic movies, I see this just fine

.
To do this, I used this formula:

.
I put the category name into the Text Input field, so that whatever I put there, the horizontal list updates dynamically.

Now, I select these two components, and make them into a list like so

And I get this:

.
.
Now here’s the confusing part. I change the Input Field so that it displays the name of the Category

And in the app preview, the name of the category shows up just fine, but the movies inside it doesn’t. All the lists are showing the one movie which has no category assigned to it in the Airtable base

Here’s a look at the formula (same formula being used in the other page that worked)

Bumping this thread in hopes that someone will know what to do here :frowning:

Hi @AddyEdwin ,
Had this on the back-burner. I investigated your issue with Airtable and Adalo. With Airtable it seems to be an issue with Adalo not accepting “2nd level Formulas”, so it is not possible to filter the movies inside the Category list.I would contact Adalo regarding this (I see there is another topic similar to this also in the forum with same issue and no resolution)

With Adalo collections, this is possible, as long as you create the relationship between movie (Category can have many movies while movie can only have one category).

As you can it worked this way:

Unfortunately for now, there is no visible solution with Airtable.

1 Like

Thank you so much for investigating it! At least knowing that it doesn’t work right now is a relief, so that I can find alternatives. Hope this gets fixed soon. While I’m marking this as a solution, I’m also raising a bug request to support.

Edit: for some reason I can’t mark any post as a solution. Weird. Will try again later

Welcome :slight_smile: .
Definitely sorting out the bug would be very beneficial for Airtable users. I would just build the APP in Adalo for now and mix with Airtable when you can, if you can’t wait at least for now, and later the change should be minimal. Often I mix Adalo collections with Airtable due to this same limitations. Cheers.

1 Like