Plyr Video not playing AWS or Backblaze files

I am trying to use the Plyr component for playing video files. I have tried both Backblaze B2 and AWS S3 with .mp4 file but neither option allow me to play them in Plyr.

1 Like

I believe this is a bug as I cannot get it to work with any web based video. It may be the case that it only works with locally saved videos and I know it only works with MP4. I would suggest submitting a support ticket in this instance but you must bear in mind that the plugin is not created by Adalo so support may be limited.

As an alternative you could always use the web view which does work as I have just tested it.

Cheers
Craig

Hello,

May I know if you checked out the next topic, please?

In short, you might have the CORS issue, and you need to allow Adalo to preview your videos.

Let me know if you have any questions, please.

Have a good one!

hey @jaronhumiston could you try playing the video again in the adalo previewer, but open your browser console to see if any error messages pop up?

using chrome is easiest → Open Chrome DevTools  |  Google Developers

I did check out that topic and made those changes. I now have a couple of videos that play but the majority of them dont.

Check to see of any errors show up and I am getting a “Resource interpreted as Document but transferred with MIME type video/mp4: “https://d32owm4axk349k.cloudfront.net/Media/Alpha/Episode+13++Church+What+about+the+church_.mp4”.”

When I check the network option is developer tools, the 2 videos that do play are showing as “media” under type. The videos not playing are showing as type “other”

I cannot open that link. Can you please have a look at this?

Hmm this is the link from the database - https://d32owm4axk349k.cloudfront.net/Media/Alpha/Episode+13++Church+What+about+the+church_.mp4

it plays just fine on my end

Please try to copy it and open it via incognito mode.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.