Preview not showing all components

Hello! I have a background image with text on top. In the Adalo builder view, everything appears correctly, but in preview, only the background image is showing. See screenshot with current set up. In Preview, the text in the white circle is not appearing.

Have you tried using the background image feature (under edit styles in the left panel when the whole screen is selected) rather than an image component

This issue popped up again on another page where text field is not appearing on top of a rectangle in the preview.

Likely the issue is that your header component is set to be fixed top in it’s edit styles are and your hello text component is now. Components that are fixed position will always appear above ones that aren’t

Thank you! I turned them into a group and fixed that to the top.

Hello @Ben!

When I’m setting background image and preview on Adalo web it’s showing perfect but when I want to preview on my mobile using Adalo mobile preview application on that time background image disappeared (Showing white background). I need a color gradient effect that’s why I have to use a image instead of solid color. When I’m using solid color it’s okay.

waiting for your feedback. Thanks a lot

We’ve deprecated support for the Adalo Previewer Android app, so it doesn’t support features that have been added since such as screen background image.

1 Like

So it’s not going to work if you have an image on background (such as the one above)?

Yes @Tommen this ins only when try to preview.