Previewer returning invalid response error message

Hi all,

I apologize if this is a rudimentary question, but I searched for it in the forums and didn’t find anything that answers my specific problem, only adjacent problems.

When I click preview I get the broken file frown icon and when I hover my cursor over it the error message reads “ sent an invalid response”

This is BEFORE the start page of my app or ANY other content is available. Therefore, I cannot preview ANY aspect of the app I am trying to build on ANY of the available phone and tablet templates.


Hi @ProfHoward,

Welcome to the forum!

This is something which shouldn’t happen :frowning:
I’d suggest doing the following:

  • try to open the app builder and launch preview in the browser incognito window (so that no previous cookies and cache exist)
  • try to open the app builder in different browser

If the problem persists, it might be a good idea to submit a support ticket here: Submit a Support Ticket

Also, it is worthwhile to check if the problem is related only to one app or all of your apps.

Best regards, Victor.

Hi Victor,
Thanks for your speedy reply!

I tried to use the preview mode in incognito on chrome and got the same error message. Then, I cleared my cache and cookies and tried again, same error message.

Using Safari, I get no error message but the preview phone screen is just black.

Using a fresh install of firefox, I am getting the following message: Secure Connection Failed

An error occurred during a connection to SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

I am trying to develop an app that serves as an ala carte learning tool for my biology students, so I am working in the free version until I verify that it works and does the things I want it to do, I was then planning on purchasing a paid version. However, if I can’t test it I may abandon the effort.

I will now go try and build a dummy app to see if I get the same errors and then get back to you.

Hi @ProfHoward,

Sure, I understand - without possibility to test it makes little reason to upgrade :slight_smile:

From my point of view, it will be difficult to do anything from a user/maker side with such error. As I said, I’d advice submitting a support ticket to get a response from Adalo’s support team.

Testing on a dummy app is useful anyway - at least you’ll understand whether this is related to your account in general or just to a single app. This information will also be useful for support.

Best regards, Victor.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.